cancel
Showing results for 
Search instead for 
Did you mean: 

Problema Installazione Magento su MAMP

Problema Installazione Magento su MAMP

Ciao ragazzi.

Sono nuovo su Magento, questo è il primo sito che sto iniziando a realizzare.

Ho però subito riscontrato un problema tentando di installare il CMS sul server virtuale MAMP.

Riporto con uno  gli errori che non mi hanno permesso di proseguire con l'installazione.

 

  • PHP Settings Check

    Your PHP Version is 5.6.8, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

    For additional assistance, see PHP settings check help .

      (impostato a -1 ma mi da lo stesso errore)

 

 

  • PHP Extensions Check

    2 missing PHP extensions. Hide detail

    The best way to resolve this is to install the correct missing extensions. The exact fix depends on our server, your host, and other system variables.
    Our PHP extension help can get you started.

    For additional assistance, contact your hosting provider.

     

    • X PHP Extension xsl.
    • X PHP Extension intl

    (non so come risolvere)

     

     

    Potreste darmi una mano a risolvere questi problemi? Ve ne sarei davvero molto grato Smiley Very Happy

    Cordiali saluti,

    Fabio

 

19 REPLIES

Re: Problema Installazione Magento su MAMP

Ciao, che versione di Magento stai installando? Su magento 1 non mi pare che si blocchi in assenza di quei moduli. 

Per le impostazioni di Php, quale file php.ini hai modificato? MAMP con la tua versione di php va a caricare quello che è sotto 

/Applications/MAMP/bin/php/php5.6.8/conf/php.ini

modificando quello ti dovrebbe prendere l'opzione. 

 

Sempre nello stesso file puoi abilitare il modulo xsl rimuovendo il commento alla riga:

extension=php_xsl.dll

Ricordati sempre di riavviare il server MAMP dopo che hai fatto delle modifiche.

Per installare intl è un po' più complesso, trovi delle istruzioni qui:

Ti servirà di avere Xcode installato e possibilmente Brew per installare dei pacchetti da terminale. 

 

 

 

 

 

Paolo Vecchiocattivi -- http://www.magespecialist.it
// Converting code to business

Re: Problema Installazione Magento su MAMP

Ciao grazie per la risposta.

Allora nel percorso che mi hai indicato tu, dopo che entro nella cartella: 

MAMP/bin/php/php5.6.8/

Non è presente la directory "conf", ti informo che uso MAMP da Windows non da Mac, forse è per questo.

La versione che sto provando ad installare di Magento è la 2.0.2 cioè l'ultima.

Mi consigli di utilizzarne una precedente?

Re: Problema Installazione Magento su MAMP

Purtroppo non ho esperienza diretta di Magento 2 su MAMP sotto Windows, comunque dalla documentazione il file php.ini da modificare si dovrebbe trovare sotto 

c:\MAMP\conf\php5.6.8\

Non sono riuscito a trovare nulla però per l'installazione di intl, al limite potresti provare con WAMP che dovrebbe averlo tra i moduli da attivare. 

 

Se stai provando Magento 2 inoltre ti converrebbe utilizzare PHP 7, perché ti dà un grosso incremento di prestazioni soprattutto per la modalità di sviluppo. 

Paolo Vecchiocattivi -- http://www.magespecialist.it
// Converting code to business

Re: Problema Installazione Magento su MAMP

Ok quindi mi consigli di utilizzare una versione 1.9.x.x??

Poi dato che mi trovo volevo chiederti un'altra cosa:

Mi sapresti indicare uno o più buoni Hosting performanti in Italiano per utilizzare Magento? 

Ieri ho dato un' occhiata a Serverplan, ma cercavo se fosse possibile un qualcosa di un pò più economico (max 50 euro l'anno).

Re: Problema Installazione Magento su MAMP

Dipende molto da quali sono le tue intenzioni, se vuoi iniziare a familiarizzare con Magento anche una 1.9 può essere un buon inizio, ma considera che verrà dismessa dato che esiste già la 2 che è la versione ufficiale e che le differenze sono parecchie sia fuori che dentro il cofano.

Per quanto riguarda l'hosting anche qui dipende quale sia lo scopo.
Magento è un sistema di ecommerce enterprise level con certi requisiti anche prestazionali, se dovessi basarci un business mi rivolgerei a degli hosting specializzati, che ti offrono delle risorse ottimizzate ma che non hanno sicuramente un basso costo.
Se devi solo sperimentare direi che uno vale l'altro, basta stare nei requisiti minimi della piattaforma.
Paolo Vecchiocattivi -- http://www.magespecialist.it
// Converting code to business

Re: Problema Installazione Magento su MAMP

Io sarei più orientato a partire direttamente con la versione 2. Devo riuscire ad utilizzarla in locale. Provo con XAMPP che dici?

Re: Problema Installazione Magento su MAMP

Anche con XAMPP non dovresti avere problemi, è sufficiente attivare i moduli necessari dal php.ini.

Paolo Vecchiocattivi -- http://www.magespecialist.it
// Converting code to business

Re: Problema Installazione Magento su MAMP

Allora ti aggiorno.

Sto provando ad installare su Xampp la 2.0.2, il primo step è andato a buon fine.

Ora c'è però un secondo problema:

Quando inserisco i dati del Database creato su PhpMyAdmin, mi esce questo errore:

Sorry, but we support MySQL version 5.6.0 or later.

Come faccio ad ovviarlo?

Devo aggiornare il PHPMYADMIN di XAMPP?

Re: Problema Installazione Magento su MAMP

Non so se Xampp fornisce più versioni di MySQL, eventualmente puoi scaricare la versione più recente e modificare le configurazioni di Xampp.

 

In alternativa, puoi provare Ampps, fornisce diverse versioni sia di php che di mysql e permette di cambiare rapidamente la versione che ti occorre.

 

------------------ [ Antonio Carboni ] ------------------Hosting Magenio
Problema risolto? Clicca Accept as Solution!