cancel
Showing results for 
Search instead for 
Did you mean: 

Problema con PHP 5.3.0

Problema con PHP 5.3.0

Ciao a tutti Voi e complimenti per il lavoro svolto su Magento Forum.

Sono approdato qui dopo disperate navigazioni quasi ovunque per il Web!

Sto imparando ad usare Magento, ed ecco che dopo aver installato le release 1.9.1.0, il server mi risponde che :

 

"Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.3.0 or newer. Find out how to install Magento using PHP-CGI as a work-around."

 

Ho contattato l'host e mi hanno risposto che potrebbe essere solo una semplice informazione, inquanto hanno installato mysql-version 5.5.40

 

Ho cambiato anche i permessi nelle cartelle " app, etc, var e media" impostandoli a 777, ma il problema persiste....!!!

 

Vista il mio scarso know-how, sono "salpato" alla ricerca di possibili soluzioni, ed eccomi quì...!!!

 

Nella speranza che il mio problema e una vostra risposta possano servire anche ad altri neofiti, rimango in attesa di leggervi quanto prima...

 

Grazie, Maxximilian

 

11 REPLIES

Re: Problema con PHP 5.3.0

Check this page http://magento.com/resources/system-requirements

 

(Sorry, I can't write in italian)

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Problema con PHP 5.3.0

Hi Damian,

 

thank You a lot for Your appreciate suggestion. Unfortunately I have already cheked on the this link, and evrythings appear right setted...!!!

 

In evry case You are a welcome for this "tips".....

 

Maxximilian

Re: Problema con PHP 5.3.0

so what is your php version actually?

------------
MagenX - Magento and Server optimization

Re: Problema con PHP 5.3.0

... Ciao a tutti problema risolto...Smiley Indifferent

 

Quando ho capito il problema sono rimasto basito.....!!!

 

Mea culpa, mea culpa, mea grandissima culpa !!!!

 

Avevo dimenticato di aggiungere nella "root" il file ".htaccess" 

 

Ora tutto funziona - ovviamente - , ma come sempre, la fretta è cattiva consigliera.....

 

Grazie a tutti per l'interessamento, e spero che questo mio errore possa essere di aiuto anche ad altri....

 

Maxximilian

Re: Problema con PHP 5.3.0

Ciao,

già che ci sei ripristina i permessi su file e cartelle, non è consigliabile lasciare 777: http://www.magentocommerce.com/knowledge-base/entry/install-privs-after

 

Un saluto

Alessandro Ronchi -- https://github.com/aleron75

Re: Problema con PHP 5.3.0

Ciao aleron75,

grazie per il consiglio.... Questa mi sembra già una cosa un pò piu difficile da fare, anche perchè non ho la cognizione logica di cosa devo fare....

 

Allora riassumendo...

 

> Abilito i permessi di scrittura e lettura su file e cartelle "soliti"

> ..... ????? Cosa faccio nel frattempo...???  Modifico, carico immagini? etc..... E per ultimo... (Prossimo step...)

> E riabilito i permessi originari ? Nel senso che ..... ripristino i valori nelle cartelle com'erano prima che abilitassi ipermessi di scrittura e lettura ??

 

Forse la mia è una domanda stupidamente ovvia, ma Magento non lo è affatto !!!Smiley Indifferent

 

 

Re: Problema con PHP 5.3.0

Ciao,

hai accesso ssh al server? L'ideale per ripristinare i permessi è seguire il tutorial che ti ho indicato.

 

Mi è venuto in mente anche che se ti mancava il file .htaccess in root magari ti manca anche nelle altre cartelle ed è importante che ci sia; ad esempio è presente anche in cartelle come  app, var, media

 

Un saluto

Alessandro Ronchi -- https://github.com/aleron75

Re: Problema con PHP 5.3.0

Ciao Alessandro,

grazie  per la risposta... Giust'appunto il file .htaccess...

 

Nella versione che ho installato 1.9.1.0 nella directory media c'è un piccolo file .htaccess di 533 byte che ho dovuto rimuovere, diversamente non era possibile caricare le immagini nel dbase..... Appena l'ho tolto..... Voilà.... le immagini sono comparse !!! Sono turbato per questa cosa !!!

 

Rispondo alla tua domanda.... No! non ho un accesso ssl, vorrei richiederlo all' hosting di poterlo attivare.... 

 

Ho letto il tutorial che mi hai indicato, ma per le mie scarse competenze è davvero difficile.....!!! Ma ci vorrei provare....

 

Ora lo store è in fase di popolamento in un area test, ma "gira"... Nel frattempo vorrei potermi dedicare al SSL & Co.... e capire perchè da ogni installazione devo rimuovere quel piccolo file...!!!

 

Grazie,

 

Massimiliano

 

 

 

 

 

 

 

 

 

 

Re: Problema con PHP 5.3.0

Ciao, visto che è una giornata che cerco di capire lo stesso errore ed ho trovato te che parli italiano, mi potresti dire dove devo cercare ed inserire htaccess? Sperando che sia quello l' errore. Thanks