cancel
Showing results for 
Search instead for 
Did you mean: 

problema con le estensioni

problema con le estensioni

Salve,

 

ho installato Magento 2 direttamente tramite il server che ospita il sito.

Purtroppo però, non riesco ad installare le estensioni tramite magento connect.

Mi da una serie di errori che non riesco a correggere in alcun modo.

Non trovo poi da nessuna parte il file php.ini che dovrei modificare per correggere alcuni errori.

Al massimo trovo php.ini.sample che non c'entra nulla...

Spero possiate aiutarmi.

Vi ringrazio

Tiziana

 

errore1.pngerrore2.png

 

4 REPLIES

Re: problema con le estensioni

A quanto pare il server che ospita il sito non è configurato (men che meno ottimizzato per Magento).

Ti consiglio di cambiare servizio o se il servizio lo consente, di far configurare opportunamente il server da un sys administrator specializzato in Magento.

 

------------------ [ Antonio Carboni ] ------------------Hosting Magenio
Problema risolto? Clicca Accept as Solution!

Re: problema con le estensioni

Ciao! Grazie intanto per la tua risposta.

Il server è su Serverplan e ho fatto diverse ricerche prima di scegliere loro, proprio perché la mia intenzione era trovare qualcosa che andasse bene per Magento.

(Prima ero su aruba e ho cambiato appositamente da pochissimo) Non l'ho scelto a caso insomma.

Re: problema con le estensioni

Torno a scrivere per dire che il supporto tecnico mi ha dato una mano e ha risolto quasi tutti i problemi che riscontravo.

Rimane purtroppo il problema Check Component Dependency di cui non trovo alcuna soluzione...

 

Check Component Dependency

 

We found conflicting component dependencies. Show detail Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for magento/product-community-edition 2.1.7 -> satisfiable by magento/product-community-edition[2.1.7].
- magento/module-robots 100.2.0 requires magento/framework 101.0.* -> satisfiable by magento/framework[101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 101.0.0].
- Can only install one of: magento/framework[101.0.0-rc21, 100.1.7].
- Can only install one of: magento/framework[101.0.0-rc22, 100.1.7].
- Can only install one of: magento/framework[101.0.0-rc23, 100.1.7].
- Can only install one of: magento/framework[101.0.0-rc30, 100.1.7].
- Can only install one of: magento/framework[101.0.0, 100.1.7].
- magento/product-community-edition 2.1.7 requires magento/framework 100.1.7 -> satisfiable by magento/framework[100.1.7].
- Installation request for magento/module-robots 100.2.0 -> satisfiable by magento/module-robots[100.2.0].

Re: problema con le estensioni

Purtroppo non so cosa comporti l'installazione con i tool automatici, spesso creano confusione con versioni non aggiornate.

Ad ogni modo c'è un problema di dipendenze, è probabile che l'installazione abbia installato pacchetti obsoleti o che il modulo richieda una versione particolare di un pacchetto.

 

Dovresti lanciare un composer update o cambiare la versione del modulo richiesto dal composer.json del progetto.

 

------------------ [ Antonio Carboni ] ------------------Hosting Magenio
Problema risolto? Clicca Accept as Solution!