cancel
Showing results for 
Search instead for 
Did you mean: 

Admin Login broken after installing extension. Help!

SOLVED

Admin Login broken after installing extension. Help!

Version 1.9 I donwloaded this extension

 

https://www.magentocommerce.com/magento-connect/product-attachments-extension.html

and installed via magento connect. I uploaded the .tar file from my local machine. The installation seemed to work OK. No error messages.

 

But when I try to login as an administrator I get

"There has been an error processing your request"

 

Here's a copy of the error from from var/reports

 

: a:5:{i:0;s:75:"Mage registry key "_singleton/fileuploader/observer_product" already exists";i:1;s:2690:"

#0 /home/sel/domains/xxxx/public_html/app/Mage.php(223): Mage::throwException('Mage registry k...')

#1 /home/sel/domains/xxxx/public_html/app/Mage.php(477): Mage::register('_singleton/file...', false)

#2 /home/sel/domains/xxxx/public_html/includes/src/__default.php(21823): Mage::getSingleton('fileuploader/ob...')

#3 /home/sel/domains/xxxx/public_html/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('core_block_abst...', Array)

#4 /home/sel/domains/xxxx/public_html/includes/src/__default.php(1988): Mage::dispatchEvent('core_block_abst...', Array)

#5 /home/sel/domains/xxxx/public_html/includes/src/__default.php(28232): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))

#6 /home/sel/domains/xxxx/public_html/includes/src/__default.php(28248): Mage_Core_Model_Layout->createBlock('adminhtml/page_...', 'head')

#7 /home/sel/domains/xxxx/public_html/includes/src/__default.php(28015): Mage_Core_Model_Layout->addBlock('adminhtml/page_...', 'head')

#8 /home/sel/domains/xxxx/public_html/includes/src/__default.php(27981): Mage_Core_Model_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))

#9 /home/sel/domains/xxxx/public_html/includes/src/__default.php(27982): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))

#10 /home/sel/domains/xxxx/public_html/includes/src/__default.php(14024): Mage_Core_Model_Layout->generateBlocks()

#11 /home/sel/domains/xxxx/public_html/includes/src/__default.php(13949): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()

#12 /home/sel/domains/xxxx/public_html/includes/src/Mage_Adminhtml_Controller_Action.php(275): Mage_Core_Controller_Varien_Action->loadLayout(NULL, true, true)

#13 /home/sel/domains/xxxx/public_html/app/code/core/Mage/Adminhtml/controllers/IndexController.php(81): Mage_Adminhtml_Controller_Action->loadLayout()

#14 /home/sel/domains/xxxx/public_html/includes/src/__default.php(14098): Mage_Adminhtml_IndexController->loginAction()

#15 /home/sel/domains/xxxx/public_html/includes/src/__default.php(18514): Mage_Core_Controller_Varien_Action->dispatch('login')

#16 /home/sel/domains/xxxx/public_html/includes/src/__default.php(18044): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))

#17 /home/sel/domains/xxxx/public_html/includes/src/__default.php(20861): Mage_Core_Controller_Varien_Front->dispatch()

#18 /home/sel/domains/xxxx/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)

#19 /home/sel/domains/xxxx/public_html/index.php(87): Mage::run('', 'store')

#20 {main}";s:3:"url";s:21:"/index.php/sel-admin/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

 

(I replaced the domain name with xxxx)

 

Maybe I should delete the new extension files by hand? Would that revert the magento installation to its previous state?

3 REPLIES

Re: Admin Login broken after installing extension. Help!

I partially fixed the problem by disabling the extension. by editing the relevant xml files in app/etc/modules.

 

Now I can login again. I'm still wondering what went wrong with the extension installation.

 

 

 

 

 

 

 

Re: Admin Login broken after installing extension. Help!

Hi @Piert

 

Are you using magento compilation feature? I suspect yes, if yes then first disable it then install the extension and re enable compilation.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Admin Login broken after installing extension. Help!

Thanks Muk!!! That did the trick.

 

------------

 

EDIT : I spoke too soon. I disabled compilation and successfully installed the extension, but when I re-enabled compilation the same error occurred. So it is not fixed...