cancel
Showing results for 
Search instead for 
Did you mean: 

Emails not sent in 1.9.1

SOLVED

Emails not sent in 1.9.1

Hi there,

I have upgraded to CE 1.9.2.2 however order emails and the like are not getting sent.  I am on CentOS have a cron set up like this:

 

 */5     *       *       *       *       apache /bin/sh /var/www/store/cron.sh cron.php -m=default
 */5     *       *       *       *       apache /bin/sh /var/www/store/cron.sh cron.php -m=always

 

I have entries in core_email_queue like this:

 

*************************** 95. row ***************************
  message_id: 95
  event_type: new_order
  created_at: 2015-12-16 18:43:25
processed_at: NULL
*************************** 96. row ***************************
  message_id: 96
  event_type: new_order
  created_at: 2015-12-17 09:24:55
processed_at: NULL

 

and in core_email_queue_recipients like this:

 

*************************** 211. row ***************************
   recipient_id: 211
     message_id: 96
recipient_email: recipient@mystore.com
 recipient_name:
     email_type: 2
*************************** 212. row ***************************
   recipient_id: 212
     message_id: 96
recipient_email:  recipient2@mystore.com
 recipient_name:
     email_type: 2

 

I'm not seeing anything related to email issues in system.log or exception.log

 

Can anyone tell me where to look next please?

Thanks

Ben

 

3 REPLIES

Re: Emails not sent in 1.9.1

Also, under System > Configuration > Advanced > System > Cron my settings are:

Generate Schedules Every 15
Schedule Ahead for 20
Missed if Not Run Within 15
History Cleanup Every 10
Success History Lifetime 60
Failure History Lifetime 600

Re: Emails not sent in 1.9.1

Still stuck on this, if anyone has any ideas?

Thanks in advance

Ben

Re: Emails not sent in 1.9.1

Got it!

 

Just needed to remove the user from the crontab entry:

 

 */5     *       *       *       *       /bin/sh /var/www/store/cron.sh cron.php -m=default
 */5     *       *       *       *       /bin/sh /var/www/store/cron.sh cron.php -m=always