cancel
Showing results for 
Search instead for 
Did you mean: 

Having 404 not found error while change http into https

Having 404 not found error while change http into https

Dear,

 

When i am change http into https, go to front and back end both it says 404 page not found  error

 

But i have to open http like http://www.mysite.com its working fine. instead of like https://www.mysite.com to open its come to this error

 

Please kindly help me..

6 REPLIES

Re: Having 404 not found error while change http into https

Hello prema92,

 

You use Apache or Nginx? Did you make any configuration for your web service?

You try Magento Admin > Configuration > Web > Secure

+The {{secure_base_url}} should be changed to https://www.domain.com (https://)

+Use Secure URLs in Frontend > Yes

+Use Secure URLs in Admin > Yes

If your Browser has any warning, please try to process any way.

Problem solved? Click Accept as Solution!

Re: Having 404 not found error while change http into https

hai,

 

yes sir, in back end done all above changes already.

 

Then i did all the changes from httpd.config,httpd-ssl.conf and httpd-vhosts.conf files in localhost apache server.

 

Its works in other core project except magento project. In magento projects only return 404 page not found error both front end and backend

 

can you help me..

Re: Having 404 not found error while change http into https

Hello prema92,

 

You work on local computer or other servers? If you work on local, you should revert on changed files. Don't need to change on your local computer.

You can give me your links to reference your config files?

Problem solved? Click Accept as Solution!

Re: Having 404 not found error while change http into https

Dear,

I solved this problem in live.Now dont need to check in local computer. 

 Thank you once again..

Re: Having 404 not found error while change http into https

Hello prema92,

 

You can share how to solve your problem?

Problem solved? Click Accept as Solution!

Re: Having 404 not found error while change http into https

Hai..

 

In local machine does not work still now. You can try it into live,its work fine

 

Put it into this below code in .htaccess file from  <IfModule mod_rewrite.c>

 

step:1

RewriteEngine on
#RewriteCond %{HTTPS} off
#RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] 

 

step:2

In admin panel, Enable the secure url and unsecure url

 

Thanks & Regards,

Premalatha.S