cancel
Showing results for 
Search instead for 
Did you mean: 

I get this bootstrap error 411 while starting installation:

I get this bootstrap error 411 while starting installation:

Dear  All, 

Greetings!

 

I get below error while installation begining process...
Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /home/ym/public_html/vendor/magento/framework/App/Bootstrap.php on line 411

 

Will you please help to fix this error?

 

Samu

6 REPLIES

Re: I get this bootstrap error 411 while starting installation:

This is pure syntax error, which could mean any number of things. In your case I think it's caused by unsupported PHP version.

Tanel Raja

Re: I get this bootstrap error 411 while starting installation:

how to solve it?

Re: I get this bootstrap error 411 while starting installation:

You need to upgrade your PHP to newer version. Or if you don't know how to do it ask your hosting provider. There's also a small matter of your Magento version, as not every Magento release supports every PHP version, but generally when you upgrade to 5.6 all should be well. Please note that Magento 1.x does not support PHP 7.

Tanel Raja

Re: I get this bootstrap error 411 while starting installation:

Hi Tanel,

Greetings!

Thank you so much for replying on my question. you are right. After your post, I actually asked to hosting provider they later changed to PHP version and installation further proceed however on hosting hostgator their MySQL support only 5.6.0 or later so I stopped there. The hosting said to use 1.9 .0 magento version due to their MySQL version support.

 

Also, I seek your advice that the hosting tech person told me that magento will be slow in normal hosting, he suggested me to use VPS for faster exection.. will you please suggest on this, is it true that we need VPS for magento? Are all magento are hosted in VPS or?

 

Thank you Tanel, appreciate you. I really appreciate Magento Forum's active community for receiving help for new user like me.

 

Samu

 

 

Re: I get this bootstrap error 411 while starting installation:

Well how much horsepower you need depends on many factors: how well your Magento is optimised, how many visitors do you get and so on. There are two big differences between Virtual server and VPS/Cloud server and while generally VPS boxes are indeed faster, the speed is not one of them. Those two things are:

 

  1. You have full control over virtual machine (VPS means Virtual Private Server), which is both benefit (you can install whatever you want, you have total control over it) and responsibility/complication (you need to install / update / upgrade everything yourself). Virtual servers are kind of as-is thing, you only get access to your own files and IPS takes care of everything else. This is actually pretty **bleep** convenient by the way.
  2. You get dedidcated resourcess from ISP. Virtual servers generally share common resource pool which means that whenever any of them decides not to play nice everyone else on this node will suffer. While it's strongly discouraged by ISP it happens and when your store is big enough, it's usually not the risk you want to take. By the way, it works other way around as well.

So eventually everything boils down to the project budget: smaller stores prefer to use virtual servers as ISP takes care of all hosting related stuff. Bigger store use VPS-s and even bigger ones use private servers. Beyond that there are stores bigger still who use server clusters.

Tanel Raja

Re: I get this bootstrap error 411 while starting installation:

Hello, Guys,

I have got the same error. But installation is quite impressive. I have no issues in installation. Everything went well. While clearing cache and reindex via SSH command line. I got the same error described above. 

I'm on GoDaddy Shared Hosting. My current PHP version = 7.0.2 and MySQL 5.6. How can I overcome this issue?. 

But my command line is pointing my current PHP version - 5.4.45. 

I used to get PHP version through command line using this syntax. (php -i)

To overcome this PHP error. I have created a "phpinfo" page. Where my info page comes up with the version of 7.0.2.

I have done everything I could to resolve this issue. 

I have reached out contact centre for help. But they're unable to resolve my issue.

GoDaddy infrastructure, they're using cloud Linux + WHM/cPanel.  Is this anything I should rewrite with Bootstrap.hp