cancel
Showing results for 
Search instead for 
Did you mean: 

No System → Web Services → REST - OAuth Consumers

No System → Web Services → REST - OAuth Consumers

I am trying to integrate Magento with Helpscount:

http://docs.helpscout.net/article/455-magento-rest-api

 

To do this I need to go to System → Web Services → REST - OAuth Consumers.

 

The issue is that I don't have this option:

https://www.evernote.com/l/ACaohUXdzSxI5KeQ_da5PLziq-HI8TqsgCw

 

I am using 1.9.0.1

 

Any ideas?

7 REPLIES

Re: No System → Web Services → REST - OAuth Consumers

Hi @a1anm,

 

If you don't have access I'm not sure how you'll create the consumers keys.

You'll need to ask for those access rights or maybe another administrator can help you.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: No System → Web Services → REST - OAuth Consumers

I have full site access so I should be able to do this. Do you know why this option wouldn’t be showing up?

Re: No System → Web Services → REST - OAuth Consumers

@a1anm,

 

There isn't a reason ir you have full access. Only a 3rd-party module can be hidding the option.

Can you you on Permissions if you user/role has the full acess? Also, if you try to edit a role you'll be able to check if that option is available.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: No System → Web Services → REST - OAuth Consumers

I checked and my permissions are set to full.

 

I deselected this option and manually ticked all of the permissions in OAuth.

 

Logged out/in but still don't have those options!

Re: No System → Web Services → REST - OAuth Consumers

@a1anm

What options do you have in REST Roles and REST Attributes ?

 

This is what I see in our standard CE 1.9.2.3

 

-- Best regards --
Kent Christiansen / @KentChrDK / Magento Certified Solution Specialist / Visit my site (DK)

Re: No System → Web Services → REST - OAuth Consumers

@KentChr_DK

 

I only have 4 options in that menu

 

 

admin.png

Re: No System → Web Services → REST - OAuth Consumers

Figured it out!!

 

Mage_Oauth was set to Disable in System > Config > Advanced