cancel
Showing results for 
Search instead for 
Did you mean: 

Problem automatic confirmation emails not received

Problem automatic confirmation emails not received

Hello,

 

I have just created my shop Magento 1.9.2.2 and my clients do not receive automatic confirmation email after placing order (bank cheque and Paypal).

 

I can not find any other solution than to click on invoice and check "send an invoice by email" for each order.

 

I made all the transactional emails of the site and I selected them in system → configuration → sales → sales mails.

 

The sending is activated, the contact address selected is good. I have configured an email copy to check and I do not get any emails either (unless I send the invoice manually)

 

After checking the phpinfo () function; On the server I checked the following configuration
System → configuration → advanced → system → E-mail sending settings
Disable e-mails: no
Server: localhost
Port (25): 25
Enter the return path: no

 

The values ​​match those found on the server.

 

The site is located on a shared server (pro) OVH.

 

If you have other ideas I am taker, any help is welcome.

2 REPLIES

Re: Problem automatic confirmation emails not received

Hi @Eric_B,

 

Since Magento 1.9 emails are not being sent directly. All emails are being stored in a queue that is handled by cron jobs.

So you need to be sure that you Magento cron job is properly configured.

You can check how-to here: http://devdocs.magento.com/guides/m1x/install/installing_install.html#install-cron

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Problem automatic confirmation emails not received

Hello, thank you for your answer, sorry to reply to you later.


I had to check with my web host. Not having access to SSH, a cron spot is now scheduled on the cron file of my PHP server.

 

I was able to program a cron spot via the interface of my shared host but the deadline is one hour minimum.

Despite this configuration, the email list is not processed. So I tested it in manual the cron.php file,
I get a 403 forbidden error. I think this is a htacess problem. I would like to know how to configure this part.

 

 

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

###########################################
## Deny access to cron.php
    <Files cron.php>

############################################
## uncomment next lines to enable cron access with base HTTP authorization
## http://httpd.apache.org/docs/2.2/howto/auth.html
##
## Warning: .htpasswd file should be placed somewhere not accessible from the web.
## This is so that folks cannot download the password file.
## For example, if your documents are served out of /usr/local/apache/htdocs
## you might want to put the password file(s) in /usr/local/apache/.

        #AuthName "Cron auth"
        #AuthUserFile ../.htpasswd
        #AuthType basic
        #Require valid-user

############################################

        Order allow,deny
        Deny from all

    </Files>
Thank you for the help already provided