cancel
Showing results for 
Search instead for 
Did you mean: 

Swatches not updating

Swatches not updating

Hi, 

 

I have just been uploading some new colour swatches for a client, using FTP.  As it is a little quicker than completing through Admin.

 

But I have just noticed something with one swatch, even though the swatch.png is a different colour, and when uploading it overwrote the previous .png and checking the image URL, the colour swatch remains the same as previous not the updated version. 

 

So I upload via product admin to make sure I wasn't going bonkers...and still the image isn't updating. 

 

Has anyone else come across this before?

4 REPLIES

Re: Swatches not updating

Hi,

 

It may be folder permission issue. Give 777 permission to that folder.

 

Regards

Re: Swatches not updating

Hi, 

Sorry for the delay in responding, the media folder already has

 

I have just uploaded a new image called pharoah.png

 

The image URL on the website (inspect) is http://www.mywebsite.com/media/catalog/swatches/1/26x26/media/pharoah.png

 

So I have FTP'd the image pharoah.png to media/catalog/swatches/1/26x26/media/ 

 

And the image has not changed on front end. 

 

Then I tried it in the magento admin. but instead of uploading via OCnfigurable product I uploading into the simple product for the colour pharoah.png and it worked?!? 

 

IT is highly confusing?!?!? 

Re: Swatches not updating

Just tested some more and it seems if I upload an colour swatch image via 'product description' in product admin the colour option image gets uploaded to here:

 

media/wysiwyg/swatches 

 

I have been FTPing here: /media/catalog/swatches/1/26x26/media

 

I deleted from /media/catalog/swatches/1/26x26/media and now there is no image here:  /media/catalog/swatches/1/26x26/media

 

and yet the URL of the image: http://www.synaxistheta.co.uk/media/catalog/swatches/1/26x26/media/pharoah.png  is still showing there is an image on the server at the URL where I deleted the image.

 

But now image on front end. 

 

So I then upload to /media/catalog/swatches/1/26x26/media

 

And the old image returns, http://screencast.com/t/svKDMrRoQcxW even though I have upload a new image same name different colour!! 

 

It is driving me potty!!! Smiley Happy 

Re: Swatches not updating

Here's another issue same problem...

 

This is a product with a 'Duck Egg' colour option, but if you select Size: Single, you get a different image for 'Duck Egg' than you do if you select any other size available in the drop down?? 

 

http://www.synaxistheta.co.uk/egyptian-cotton-oxford-duvet-cover.html - this is the product, I have checked the URLs of the image and it is the same whatever the size selected, but the colour option for Duck Egg is definitely changing?!?!