cancel
Showing results for 
Search instead for 
Did you mean: 

getting https to work on front end

SOLVED
Highlighted

getting https to work on front end

I have tried multiple solutions but I can't get the https to work on the front end.  It works on the back end and if I use vanilla softaculous install.  However, when I install using the Magento 1.9.2.4 and my templatemonster theme it does not give me https.  I am wondering if my secure_base_url and unsecure_base_url values are not being held correctly.  They look fine in that they are both defined as - https://example.com/      

 

I found that if I go to system -> config then the web tab then I make the 'Auto-redirect to Base URL' to NO and the 'Use Web Server Rewrites' to NO and then in the .htaccess file I add this code;

RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^ https://www.zoosting.com%{REQUEST_URI} [NE,L,R=301]

 

I can get the https://example.com   to be my website.  However the page does not display correctly and this is not an ok setup. 

 

How can I fix my setup so that the frontend has https and I do not have to ruin the page?  I feel like there is something wrong with how the 'secure_base_url' and 'unsecure_base_url'  variables are behaving.  

 

would it make sense to hard code the https://example.com/ in

base link url

base skin url

base media url

base js url

?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: getting https to work on front end

I was able to find the solution.  Because I am still in the initial stages of my Magento site development, I was able to delete my setup and create a new database with the original data and start over.  When I installed I was very careful to look for any http values and noticed that on the 'Configuration' piece there is a box for unsecured that defaulted to http      I changed that box and made sure all of the http values were https    I then went through the rest of the setup and my issue was solved.  I am now secure!!      https on the front end and back end.  

 

I feel like I should have been able to make that change after initial set up but no matter what values I plugged in I could not get the front end to go to https.  So from what I observed, it must be done at setup.

View solution in original post

6 REPLIES 6
Highlighted

Re: getting https to work on front end

Hello @todd_a,

 

Can you please check base URL configuration at store level also? or Did you have SSL certificate of domain? You can check it here https://www.sslshopper.com/

 

--
If my answer is useful, please Accept as Solution & give Kudos

Highlighted

Re: getting https to work on front end

@todd_a

 

To configure Magento to work with your SSL certificate, first you need to login to your admin area and go to System -> Configuration.

Next, click on the Web link under the General tab in your left menu.

On this page, you will see many options that you can configure. However, focus only on the Secure tab. In it, make sure that you've set the Use Secure URLs in Frontend and Use Secure URLs in Admin to yes. Doing this will make your Magento application work with SSL for those parts of your site.

 

After changes these configurations please remove var/cache and var/session and then open the site in incognito mode. 

There is no need to change in Base media base skin

 

That's it, your Magento store is now configured to work over SSL!

Manish Mittal
https://www.manishmittal.com/
Highlighted

Re: getting https to work on front end

This did not work.  I have set up this way already.  I had not tried removing the folders suggested but I had used the magento clear cache and reset the indexes when making changes but so far I have not been able to make this work.

Highlighted

Re: getting https to work on front end

I doubled checked my SSL using your website.  It is good.  All green check marks.

Highlighted

Re: getting https to work on front end

Hello @todd_a,

 

Please check base url configuration on store level by selecting website and store. Might be there will be different value is set.

 

--
If my answer is useful, please Accept as Solution & give Kudos

Highlighted

Re: getting https to work on front end

I was able to find the solution.  Because I am still in the initial stages of my Magento site development, I was able to delete my setup and create a new database with the original data and start over.  When I installed I was very careful to look for any http values and noticed that on the 'Configuration' piece there is a box for unsecured that defaulted to http      I changed that box and made sure all of the http values were https    I then went through the rest of the setup and my issue was solved.  I am now secure!!      https on the front end and back end.  

 

I feel like I should have been able to make that change after initial set up but no matter what values I plugged in I could not get the front end to go to https.  So from what I observed, it must be done at setup.

View solution in original post