cancel
Showing results for 
Search instead for 
Did you mean: 

Domain giving error, when magento store moved!

Domain giving error, when magento store moved!

I have create a magento store in localhost and moved to live server.  Then I am getting the following error.  Anyone can help me on this issue.  Any guidance is appreciated.  Thanks in Advance  

 

>>  There has been an error processing your request

SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO)
Trace: #0 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111): Zend_Db_Adapter_Pdo_Abstract->_connect() #1 /home/yrkishore/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(396): Zend_Db_Adapter_Pdo_Mysql->_connect() #2 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Abstract.php(460): Varien_Db_Adapter_Pdo_Mysql->_connect() #3 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array) #4 /home/yrkishore/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(504): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array) #5 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource.php(179): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8') #6 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element)) #7 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write') #8 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write') #9 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter() #10 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter() #11 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Cache.php(478): Mage_Core_Model_Resource_Cache->getAllOptions() #12 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Cache.php(520): Mage_Core_Model_Cache->_initOptions() #13 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(1202): Mage_Core_Model_Cache->canUse('config') #14 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache('config') #15 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit() #16 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(424): Mage_Core_Model_Config->loadModulesCache() #17 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules() #18 /home/yrkishore/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array) #19 /home/yrkishore/public_html/index.php(83): Mage::run('', 'store') #20 {main}

Error log record number: 567757124803

4 REPLIES

Re: Domain giving error, when magento store moved!

That error is saying that it can't connect to the database (user is root, with no password). You need to create a new mysql user and pass, configure it in your local.xml magento config and clear any cache if enabled. If you don't want to create a new mysql user, then you have to fix the root user with no pass connecting to localhost. Here is more info on how to add a mysql user: https://dev.mysql.com/doc/refman/5.7/en/adding-users.html

Re: Domain giving error, when magento store moved!

I have changed the local.xml and sql user also existed.  But still it is giving same error.  Is there any other I have to change?

Re: Domain giving error, when magento store moved!

Still I am getting the following error.  Actually my hosting domain is godaddy -> cPanel, and localhost is Windows 7 having PHP and sql (Xampp).  Is there any need to change permissions for sql either in cPanel or Windows.  

 

SQLSTATE[HY000] [2002] Connection refused
Trace: #0 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111): Zend_Db_Adapter_Pdo_Abstract->_connect() #1 /home/yrkishore/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(396): Zend_Db_Adapter_Pdo_Mysql->_connect() #2 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Abstract.php(460): Varien_Db_Adapter_Pdo_Mysql->_connect() #3 /home/yrkishore/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array) #4 /home/yrkishore/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(504): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array) #5 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource.php(179): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8') #6 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element)) #7 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write') #8 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write') #9 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter() #10 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter() #11 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Cache.php(478): Mage_Core_Model_Resource_Cache->getAllOptions() #12 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Cache.php(520): Mage_Core_Model_Cache->_initOptions() #13 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(1202): Mage_Core_Model_Cache->canUse('config') #14 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache('config') #15 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit() #16 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(424): Mage_Core_Model_Config->loadModulesCache() #17 /home/yrkishore/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules() #18 /home/yrkishore/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array) #19 /home/yrkishore/public_html/index.php(83): Mage::run('', 'store') #20 {main}

Error log record number: 1252886394007

Re: Domain giving error, when magento store moved!

I have exported sql database in phpmyadmin from localhost.   While importing the same in phpmyadmin on cpanel, I am getting the following error...

 

Error

There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem;   can anyone resolve it? 

ERROR: Unknown Punctuation String @ 15
STR: ><
SQL: <!DOCTYPE HTML><html lang='en' dir='ltr' class='ie ie11'><head><meta charset="utf-8" /><meta name="robots" content="noindex,nofollow" /><meta http-equiv="X-UA-Compatible" content="IE=Edge"><style id="cfs-style">html{display: none;

 

SQL query:

<!DOCTYPE HTML><html lang='en' dir='ltr' class='ie ie11'><head><meta charset="utf-8" /><meta name="robots" content="noindex,nofollow" /><meta http-equiv="X-UA-Compatible" content="IE=Edge"><style id="cfs-style">html{display: none;

MySQL said: Documentation

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<!DOCTYPE HTML><html lang='en' dir='ltr' class='ie ie11'><head><meta charset="ut' at line 1