cancel
Showing results for 
Search instead for 
Did you mean: 

PHP7

SOLVED

PHP7

Since which version exactly (if at all) is PHP7 supported by M1?

Tanel Raja
6 REPLIES

Re: PHP7

Hi @Pronto

 

Till now magento has not supported Php 7 for Magento 1x series.

 

Please refer Magento system requirement

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: PHP7

Had on a sneaking suspicion that it might be the case. I noticed that they changed php detection algorithm at some point and added 5.6 support; thought that latest version might might also be friends with PHP7 but apparently I was wrong.

Tanel Raja

Re: PHP7

Re: PHP7

I know, I run currently several Magento installations on PHP7. However it's still workaround, which is not good as PHP7 has been "latest" PHP for several months and ISP-s start using it as a default version.

Anyway, people keep asking from me about PHP7 and they made me wonder if any of those small patches we saw lately did something about it ...

Tanel Raja

Re: PHP7

The Inchoo extension is a great starting point, however as others have stated it is a work in progress. 

 

I do run M1 on a PHP 5.6 instance and will randomly find a issue here or there. The step up to PHP 7 will probably include even more workarounds. If you do use PHP7, I would recommend you contribute to the Inchoo github page.

-Kris
4x Certified, Blogger @ xgento.com

Re: PHP7

 

If you don't have root to run a patch or would prefer to patch Magento manually, this post will help you to make Magento work with PHP7

 

http://www.ecomlane.com/announcements/4/How-to-make-Magento-1923-work-with-PHP-7.html