cancel
Showing results for 
Search instead for 
Did you mean: 

Add Products Function not working

Add Products Function not working

I just  installed magento 1.9.2 with a previous database.  Everything works  fine except the "add product" function does not work.

Also I cannot edit any of the hundreds of products I already have listed. When I click on either, I get the error message page of magento, There has been an error processing your request" 

 

Then there is a page of error messages, starting with 

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'rule.calculate_subtotal' in 'field list', query was: (SELECT `main_table`.`tax_calculation_rate_id`, `main_table`.`tax_calculation_rule_id`, `main_table`.`customer_tax_class_id`, `main_table`.`product_tax_class_id`, `rule`.`priority`, `rule`.`position`, `rule`.`calculate_subtotal`, `rate`.`rate` AS `value`, `rate`.`tax_country_id`, `rate`.`tax_region_id`, `rate`.`tax_postcode`, `rate`.`tax_calculation_rate_id`, `rate`.`code`, IF(title_table.value IS NULL, rate.code, title_table.value) AS `title` FROM `tax_calculation` AS `main_table`
 INNER JOIN `tax_calculation_rule` AS `rule` ON `rule`.`tax_calculation_rule_id` = main_table.tax_calculation_rule_id
 INNER JOIN `tax_calculation_rate` AS `rate` ON rate.tax_calculation_rate_id = main_table.tax_calculation_rate_id
 LEFT JOIN `tax_calculation_rate_title` AS `title_table` ON rate.tax_calculation_rate_id = title_table.tax_calculation_rate_id AND title_table.store_id = '0' WHERE (customer_tax_class_id = 3) AND (product_tax_class_id IN ('1')) AND (rate.tax_country_id = 'US') AND (rate.tax_region_id IN(0, 43)) AND (rate.zip_is_range IS NULL) AND (rate.tax_postcode IS NULL OR rate.tax_postcode IN('*', '', '11735', '11735*', '1173*', '117*', '11*', '1*'))) UNION (SELECT `main_table`.`tax_calculation_rate_id`, `main_table`.`tax_calculation_rule_id`, `main_table`.`customer_tax_class_id`, `main_table`.`product_tax_class_id`, `rule`.`priority`, `rule`.`position`, `rule`.`calculate_subtotal`, `rate`.`rate` AS `value`, `rate`.`tax_country_id`, `rate`.`tax_region_id`, `rate`.`tax_postcode`, `rate`.`tax_calculation_rate_id`, `rate`.`code`, IF(title_table.value IS NULL, rate.code, title_table.value) AS `title` FROM `tax_calculation` AS `main_table`
 INNER JOIN `tax_calculation_rule` AS `rule` ON `rule`.`tax_calculation_rule_id` = main_table.tax_calculation_rule_id
 INNER JOIN `tax_calculation_rate` AS `rate` ON rate.tax_calculation_rate_id = main_table.tax_calculation_rate_id
 LEFT JOIN `tax_calculation_rate_title` AS `title_table` ON rate.tax_calculation_rate_id = title_table.tax_calculation_rate_id AND title

 After  There is a long page of error messages having to do with "zend" and other things. 

I have 550 items listed, the pictures are in the database but do not show up on line.

I am not a tech guy so I have no idea what to do about this.

 

Can anyone please advise what I need to do to fix this?  Everything else on my site works perfect but this.

 

Thank you,

Steven

 

2 REPLIES

Re: Add Products Function not working

Did you ever resolve this? I have the same issue with an upgrade (in dev). Have tried adding the column in table manually, no result. I can fix the products issue by changing tax rule but I have lost the tax rules drop down from sales menu in the backend. Regards.

Re: Add Products Function not working

No, I had to start over again.  It appears that my database got corrupted, and there was no way to fix it. 

I probably reinstalled magento also, started over from scratch.

 

Thank you though.

Steven