cancel
Showing results for 
Search instead for 
Did you mean: 

Can't update additional_attributes

Can't update additional_attributes

hello, I'm getting crazy. I cannot update additional attributes via API WS-I compliant method. I think everything is ok, but attribute value is not updated. I tried with many attributes (msrp, and created by me) and everytime no errors in response (true is returned) but no changes to attributes. How it comes?

Please help me!

 

This is what I grab from my fiddler in the call

 

POST http://test.acscremona.com/api/v2_soap HTTP/1.1
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MS Web Services Client Protocol 2.0.50727.5485)
VsDebuggerCausalityData: uIDPowFo3TIYuqZOtc9hY6hR+sYAAAAAQNIjN2WmbEObvOkGqzhbeXJs9tGz5L9LoeeqK4MZMykACQAA
Content-Type: text/xml; charset=utf-8
SOAPAction: ""
Host: test.acscremona.com
Content-Length: 1081
Expect: 100-continue
Connection: Keep-Alive

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><catalogProductUpdateRequestParam xmlns="urn:Magento"><sessionId xmlns="">df421cad85e6c45eb89e25440ccc9d43</sessionId><productId xmlns="">4702</productId><productData xmlns=""><websites><complexObjectArray>1</complexObjectArray></websites><name>SDRAIO SCP ARMONIA PRO </name><description>SDRAIO SCP ARMONIA PRO !</description><short_description>SDRAIO SCP ARMONIA PRO </short_description><weight>0</weight><status>1</status><price>91,5</price><special_price>183</special_price><tax_class_id>2</tax_class_id><additional_attributes><complexObjectArray><key>videobox</key><value>99</value></complexObjectArray></additional_attributes><stock_data><qty>0</qty></stock_data></productData><store xmlns="" /><identifierType xmlns="">product_id</identifierType></catalogProductUpdateRequestParam></soap:Body></soap:Envelope>

4 REPLIES

Re: Can't update additional_attributes

Can you show your code you are using to send the update?

Magento Moderator since 2009
Keep Calm and Clear Cache!

Re: Can't update additional_attributes

Hello and thank you for answering. I use .NET webservice connection. the
snippet of code shows the point of interest

Dim pce As New catalogProductCreateEntity
Dim aEnt As New associativeEntity
aEnt.key = "bertoni_sku"
aEnt.value = "prova"
Dim aEnt2 As New associativeEntity
aEnt2.key = "test_attr2"
aEnt2.value = "99"

pce.additional_attributes = New associativeEntity() {aEnt, aEnt2}
pce.price = "1232.00"
Dim ureq As New
catalogProductUpdateRequest("620f182aa48f2e2c4c09c4ad84c7d675", "4702",
pce, "", "")
Dim uresp As catalogProductUpdateResponse =
x.ServiceReference1_Inchoo_SoapLogger_Model_Api_Server_Wsi_HandlerPortType_catalogProductUpdate(ureq)

price field is correctly updated, while bertoni_sku and test_attr2 no.
what's wrong?

Re: Can't update additional_attributes

Anybody can help me please?

Re: Can't update additional_attributes

I modified v2.php according to http://blog.rastating.com/adding-additional-attributes-in-magento-v2-api-in-ws-i-compliance-mode/

on a server with magento 1.7.0.2 and now it works. But unfortunately this is not my production server. The production server is magento 1.9.0.1 that - event with my new v2.php patch - still has the problem. How it comes?