cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Login to Admin After Switching to Https

Cannot Login to Admin After Switching to Https

Hello all, it's my first post here and I was hoping to find some support for a Magento site I'm trying to launch. 

 

The problem I am facing is that the admin login page will not allow me to log in even after inputting a correct username and password.  I have tried many things, from modifying the Varien.php file:

 

$cookieParams = array(
'lifetime' => $cookie->getLifetime(),
'path' => $cookie->getPath(),
//'domain' => $cookie->getConfigDomain(),
//'secure' => $cookie->isSecure(),
//'httponly' => $cookie->getHttponly()
);

 

to updating the site to use various http/https domains in the insecure/secure portion of the database (core_config_data). I am also clearing both var/cache/* and var/session/* on each new attempt. Unfortunately none of the helpful posts on the internet have solved my issue and I'm struggling to find the solution--the site is supposed to go live and nobody can log into the admin interface!

 

My site is Magento Community Edition v 1.9.1 using nginx 1.6.2 as the web server. I am storing sessions via the "file" method, set in local.xml. I have checked, and the permissions are set correctly so that the site can write to that directory (e.g. sess_xxx files are being created). 

 

Initially, the session files were showing a REMOTE_ADDR which was the IP address of the proxy server that sits in front of the , but I have figured how how to reconfigure the nginx server to provide the correct IP for the user in the REMOTE_ADDR portion via the nginx config line:

 

    fastcgi_param REMOTE_ADDR $proxy_add_x_forwarded_for;

 

However this does not seem to have fixed the issue either. Can anyone provide any help in this matter? I have been looking at this single issue for 3 solid days now with no clear answer in sight. 

 

Thanks in advance!

 

 

 

 

 

 

 

 

 

 

 

 

3 REPLIES

Re: Cannot Login to Admin After Switching to Https

Welcome to the forums @nathangudmu! Have you tried deleting cookies or clearing cache on your actual browser as well?

 

In case you haven't seen it, there are quite a few possible causes listed here: http://magento.stackexchange.com/questions/26071/magento-1-9-can-t-login-to-admin-panel

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Cannot Login to Admin After Switching to Https

Thanks, I will look at that page.

Re: Cannot Login to Admin After Switching to Https

Hi i am encountering the same issue. may i know if you have solved yours? 

and if so could you share your solution with me