cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot log-in from frontend

Cannot log-in from frontend

We have issues where users cannot log-in from the frontend of our website.

When customers try to log-in, the page reloads/refreshes back into the log-in screen again giving no prompts or errors.

 

But if you try the same thing in Google Chrome incognito mode the log-in will be successful.

 

After checking several forums and suggestions we have added the following code in login.phtml found in template/customer/form/login.phtml and template/persistent/customer/form/login.phtml

 

<input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey(); ?>" />

 

This did not fix the problem and we are still experiencing the same issue.

 

We are running Magento ver. 1.9.0.1 and we have a custom theme. 

 

Does anyone one have a solution to this issue?

6 REPLIES

Re: Cannot log-in from frontend

@justsc

 

Try again clearing your browser cache and it will work.

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Cannot log-in from frontend

We have cleared browser cache but overnight the issue has reoccured again.


Can you think of a reason why?

Re: Cannot log-in from frontend

PM me your website URL to check.

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Cannot log-in from frontend

Was this issue resolved?  

 

I am also having the same issue.

 

I upgraded my Magento installation last year when 1.9 came out and reversed it as I tried every mentioned fix.

 

But I figured I am a number of versions behind and decided to upgrade to 1.9.1.1-2 in the hope this bug had been ironed out and wishing I hadn't bothered.

 

Incognito works fine.  Safari fails, bog-standard android browser fails and IE also suffers the same loop back to the log in page.

Re: Cannot log-in from frontend

check System > Configuration > Web > Session, select no for all the options (try turn ;'use SID' on and see if it makes any difference),

also check System > Configuration > Web and make sure you have sorrect settings.

Re: Cannot log-in from frontend

Did you find a solution to this?