cancel
Showing results for 
Search instead for 
Did you mean: 

Disable Mage_CatalogSearch output does not work

SOLVED

Disable Mage_CatalogSearch output does not work

hello

 

I tried to disable this module output in settings to disable catalog search form in header

but there is no effect, mini form and footer links are still there

tested on Magento CE 1.7.0.2 and 1.9.1.0, cleared caches

 

I know how to do it with layout or template, just want to know if I forgot something to do it that way...

3 REPLIES

Re: Disable Mage_CatalogSearch output does not work

Hi @Dia_FR 

 

By disabling did you mean from the admin?.

 

The catalogsearch quick search is one of the few blocks in Magento not belonging to its own module for some reason ;-). So disabling the module in the admin wont work.

 

instead go to your template's local.xml file and insert the following. If your template doesn't use some sort of special name for the search box then this should remove it.

 

<default>
    <remove name="top.search" />
</default>

 

I hope this helps :-)

 

Re: Disable Mage_CatalogSearch output does not work

Hello @Dia_FR ,

 

Try to disable it from xml file and then check

/app/etc/modules

Set false in  place of true.

 

 

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Disable Mage_CatalogSearch output does not work

disabling module in app/etc/modules works as intended

 

so I think the answer of Theis Corfixen (block badly linked to module, God only knows why Smiley Tongue) is correct

 

let's make it with layout XML

 

thanks for answers