cancel
Showing results for 
Search instead for 
Did you mean: 

Don't show comment in mail wheh send from contact form - Magento:1.9.10.

SOLVED

Don't show comment in mail wheh send from contact form - Magento:1.9.10.

 

Hello,

 

I have problem with sending comments via contact form to mail.

 

If i fill contact form on site with:

 

Name

Mail

phone number

company

comment

 

i  recive on mail only:

 

Name: name
E-mail: mail
Phone number: phone number

 

And there is no comment,  and no company

 

Contact form is also set in admin pannel

 

contact.jpg

 

And code for form in form.phtml is:

 

<form action="<?php echo $this->getFormAction(); ?>" id="contactForm" method="post" class="scaffold-form">

<div class="row">

   

    <div class="col-md-6">

        <div class="form-group">

            <input type="text" value="" name="name" id="name" class="form-control" placeholder="<?php echo Mage::helper('contacts')->__('Name') ?> *" required>

            </div>

            <div class="form-group">

                <input type="text" value="" name="company" id="company" class="form-control" placeholder="<?php echo Mage::helper('contacts')->__('Company') ?> *" required>

                </div>

            <div class="form-group">

                <input type="email" value="" name="email" id="email" class="form-control" placeholder="<?php echo Mage::helper('contacts')->__('Email') ?> *" required>

                </div>

            <div class="form-group">

                    <input type="text" value="" name="telephone" id="telephone" class="form-control" placeholder="<?php echo Mage::helper('contacts')->__('Telephone') ?> *" required>

                    </div>

                </div>

            </div>

            <div class="form-group">

                <textarea name="comment" id="comment" class="form-control"  placeholder="<?php echo Mage::helper('contacts')->__('Comment') ?> *" required></textarea>

            </div>

            <div class="form-action">

                         <input type="text" name="hideit" id="hideit" value="" style="display:none !important;" />

                <button type="submit" class="btn btn-default btn-primary"><?php echo Mage::helper('contacts')->__('Submit') ?></button>

            </div>

</form>

 

 

Where can i set what shows in received mail?

 

Thanks for help,

 

A

 

 

 

 

3 REPLIES

Re: Don't show comment in mail wheh send from contact form - Magento:1.9.10.

hi alchan,

   you can check your email template. system > Transactional Emails  
Click on add Template button  and select Temaplte (Contact Form)  from Load default template Section.
at the end click on Load Template Button. you can see you email template check there are below code is added?

 

Company: {{var data.company}} 
Telephone: {{var data.telephone}}
Comment: {{var data.comment}}
Find helpful ? Consider Giving Kudos to this post.
Problem solved? Click Accept as Solution!"
Qaisar Satti

Re: Don't show comment in mail wheh send from contact form - Magento:1.9.10.

Thanks, it works!

 

i create:

Name: {{var data.name}}
Company: {{var data.company}}
Email: {{var data.email}}
Phone: {{var data.telephone}}

Comment: {{var data.comment}}

 

and then choose template form from system/configuration/contacts/email options --> template name

 

 

Re: Don't show comment in mail wheh send from contact form - Magento:1.9.10.

From your code how did you add the solution?