cancel
Showing results for 
Search instead for 
Did you mean: 

Error message "Product not exists." when using SOAP v1 catalog_product.info

Error message "Product not exists." when using SOAP v1 catalog_product.info

Hi all,

 

I am trying to use SOAP v1 to get information about given product. I am able to get list of products using catalog_product.list method.

 

However, when I try to show details for a given product using catalog_product.info method, I got an error "Product not exists." even it is listed in catalog_product.list result.

product_id = 100001

sku = 8220/B/5

 

My xml request is as follows:

<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:Magento">
   <soapenv:Header/>
   <soapenv:Body>
      <urn:call soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
         <sessionId xsi:type="xsd:string">1081236a4dd26f55e0e43ccc2668535d</sessionId>
         <resourcePath xsi:type="xsd:string">catalog_product.info</resourcePath>
         <product xsi:type="xsd:string">100001</product>
      </urn:call>
   </soapenv:Body>
</soapenv:Envelope>

 

 

and response is:

<SOAP-ENV:Envelope xmlnsSmiley FrustratedOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Body>
      <SOAP-ENV:Fault>
         <faultcode>101</faultcode>
         <faultstring>Product not exists.</faultstring>
      </SOAP-ENV:Fault>
   </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

 

Do you have any idea, what should be the problem?

 

Thank you

Magdalena

 

 

 

 

 

 

1 REPLY

Re: Error message "Product not exists." when using SOAP v1 catalog_product.info

did you try passing the SKU vs. the ProductID?