cancel
Showing results for 
Search instead for 
Did you mean: 

Quick search by SKU not working

Quick search by SKU not working

Hello,

 

i just upgraded to 1.9.1 from 1.7 and quick search with a SKU does not work.

Advanced search is working.

 

I already set attribute sku enabled both for advanced and quick search, reindex but no luck.

 

My database shows this:

catalogsearch_query

http://www.awesomescreenshot.com/image/55123/6bd3a73db17b744fb745bbd33a047dbb

 

catalogsearch_fulltext

http://www.awesomescreenshot.com/image/55136/6cbe00aca171abed6f0ac4b7b40208f3

 

catalogsearch_results

http://www.awesomescreenshot.com/image/55141/e840ed3fb578bda05b632ecbc52456f9

 

it's weird because catalogsearch_results show product id

 

Any idea how to fix this?

 

thanks

6 REPLIES

Re: Quick search by SKU not working

any help with this problem?

Re: Quick search by SKU not working

What is the Search Type set to in admin -> system -> configuration -> catalogue -> catalogue -> catalog search?

 

Cheers

S

Re: Quick search by SKU not working

Try delting your var/cache folder using an FTP program. All SQL queries are hard cached and cannot be refreshed without deleting this folder.

Enterprise Architect

800-207-1221
https://merchantprotocol.com

Magento Extension Developers

Re: Quick search by SKU not working

I noticed that if SKU is AV50F, search works. Instead if SKU is AV-50F, search is not working. Any suggest?

Re: Quick search by SKU not working

@k4net I'm finding the same thing: that if there is a hyphen in the SKU it is not searchable; no hyphen it works just fine.

 

@Saggitator My search settings are:

  • Minimal Query Length = 2
  • Maximum Query Length = 128
  • Maximum Query Words Count = 10
  • Search Type = Fulltext
  • Apply Layered Nav... = 2000
  • Show Autocomplete Results Count = Yes

I'm using Magento 1.9.2.3.

Re: Quick search by SKU not working

I changed my Search Type setting to "Combine (Like and Fulltext)" and that seems to have fixed the problem of hyphenated SKUs not being searched. I imagine "Like" would also work, but I didn't try it.