cancel
Showing results for 
Search instead for 
Did you mean: 

Registration front-end is not working on CE 1.9.2.2

SOLVED

Registration front-end is not working on CE 1.9.2.2

Hi everyone,

The registration on the front end is not working, every time i want to register an account the website page is refreshing i don't know why and i tried the different forums to find out what is the problem.

I tried the formkey : 

<?php echo Mage::getSingleton('core/session')->getFormKey() ?>

t

 i tried this too : <?php echo $this->getBlockHtml('formkey') ?>

 

but it doesn't work.

 

Is somebody could help me please ?

 

Thank you all.

Regards.

9 REPLIES

Re: Registration front-end is not working on CE 1.9.2.2

Hi @jordan_dabricot

 

Since when you started facing this issue? Did you deploy some code changes or any security patch?

Can you share the front end url?

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Registration front-end is not working on CE 1.9.2.2

Hi, 

 

Thank's for your reply, I discover this malfunction a week ago. I just modified the .htaccess to make redirections to the home page when a customer enter a wrong url and that's it but when I found the problem I've change the .htaccess to an old one and it style doesn't work.

my website : www.macinfo.fr

 

Re: Registration front-end is not working on CE 1.9.2.2

I have come to your site. I think it is good. What exact thing you have problem on?

Re: Registration front-end is not working on CE 1.9.2.2

Have you tried the registration to create an account ? Is it working for you ?

 

Because i still have this problem. Every time I want to create an account, when i enter my personal information and click on "valider"("enter" in french), the page is refreshing and nothing happened and no account is creating.

Re: Registration front-end is not working on CE 1.9.2.2

Just tested it and it worked fine for me,

 

have you looked on the backend and checked what customers have been registered?  If you have already registered your email address it won't let you register again.

Regards
Sven

Re: Registration front-end is not working on CE 1.9.2.2

UPDATE: 

 

I have just tried registering again with the same email address your validation errors are not showing at all so you will just see the page refresh.

 

Check your registration form template for 

<?php echo $this->getMessagesBlock()->toHtml() ?>
Regards
Sven

Re: Registration front-end is not working on CE 1.9.2.2

Hi, 

 

In template/persistent/customer/form/register.phtml i have 

<?php echo $this->getMessagesBlock()->toHtml() ?>

just before the <form> tag.

 

Regards

Re: Registration front-end is not working on CE 1.9.2.2

Hi it's working again

Thank you to your reply

Re: Registration front-end is not working on CE 1.9.2.2

Happy to help Smiley Happy

Regards
Sven