cancel
Showing results for 
Search instead for 
Did you mean: 

SOAP catalogProductUpdate Use Default Value

SOAP catalogProductUpdate Use Default Value

Hi

We're working with Mag V1.9.2.4 using SOAP API (...index.php/api/v2_soap...) with multiple websites and multiple storeviews.

We're able to insert and update products to provide default and storeview specific attribute values. This is done by firstly setting all attributes' default values by passing in empty storeview id to catalogProductUpdate. Then a second call to catalogProductUpdate passing in attribute values that are required to be storeview specific as non-null values with the corresponding storeview id. Magento's Admin pages show the storeview specific value and those attributes have "Use Default Values" unchecked. When catalogProductUpdate is called with a storeview id, attributes that have null values remain as default and their Admin pages shows "Use Default Value" checked.

Our problem is how to use the SOAP API to remove the storeview specific values from those attributes that have them so that their "Use Default Value" shows as checked.

We've tried passing null to those attribute values with the correct storeview id but this does nothing.

Internet searches (eg https://stackoverflow.com/questions/10313936/magento-set-product-attribute-to-use-default-values) suggest each storeview specific attribute value requires a boolean false value to revert it to "Use Default Values" but we are unable to do this with the SOAP API due to those attributes requiring String values.

Please advise how we can use the SOAP API to remove the storeview specific values from those attributes that have them so that their "Use Default Value" shows as checked.

2 REPLIES

Re: SOAP catalogProductUpdate Use Default Value

Hmm, not sure. Have you tried submitting empty strings instead of null values?

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: SOAP catalogProductUpdate Use Default Value

Thanks for the reply.

Yes we've tried empty strings but they push empty strings into the attribute value and the "use default value" remains unchecked.

We've also tried pushing the same value as default in the hope that Mag will see the value is the same and clear the storeview attribute values, but no, we just get that value as the storeview attribute value and the "use default valye" remains unchecked.