cancel
Showing results for 
Search instead for 
Did you mean: 

Server Upgraded PHP and the Site crashed..

Server Upgraded PHP and the Site crashed..

Hi,

 

The site is pretty old..the server upgraded PHP version thus crashing my site..

 

Now the site is giving the following error:

Parse error: syntax error, unexpected ')', expecting '&' or variable (T_VARIABLE) in /home/geckowho/public_html/lib/Varien/Object.php on line 463

 

I cannot even resintall or upgrade to new version. My Magento version is 1.3

 

Can anyone suggest the fixes for the above error...

 

Raj

1 REPLY

Re: Server Upgraded PHP and the Site crashed..

As you're finding, the security environment in order to keep web servers safe requires an upgrade in the php interpreter.

 

Quite literally, the longer you hold on to older versions of Magento, the more likely, you are to find that your Magento e-commerce server has been upgraded to death. You might temporarily patch 1.3 to work with newer versions of php, but it will be a very temporary measure until the next upgrade of php or mysql takes you out yet again.

 

Here's where you have to get started if you want to resurrect the current codebase, just be aware that you are on borrowed time until you get past version 1.7 and get yourself able to run on php 5.4 and beyond.

 

http://stackoverflow.com/questions/1296130/what-changes-do-i-need-to-make-magento-work-with-php-5-3

 

You will probably have to create a development server from an older version of Linux with the approprate non-internet safe versions of php, mysql in order to run this mess to attempt resurrection. Start looking at what will be needed to upgrade to 1.4.2.0 as that will be the intermediate major database overhaul before you can move on. All 3rd party and user created modules and template will need to be replaced/rewritten.