cancel
Showing results for 
Search instead for 
Did you mean: 

magento 1.9 cart VAT only correct first view

magento 1.9 cart VAT only correct first view

I don't know how to explain it in one title better.
But i got the problem that my VAT is shown correct on every page except the checkout (and cart).
And to make it even weirder the first time i go to the cart it shows correct. After that it shows incorrect!

TrT79

 

How come? Since the product page works as it should. And the tax settings are correct i have no clue at all..

Please help me out Smiley Happy Thanks in advance!


ps. I uploaded all the up to date core files over the existing system.. No solution Smiley Sad Even disabled all modules again.. Still no success.. Als re-checked all settings on tax if it's applied successfully.. And it is. I have literally NO idea how to solve this.. Please help.
specs:
- Magento 1.9.1.0 with all patches installed as they should.
- Ultimo theme(1.13.0)
- php 5.6.30
- Mariadb

 

3 REPLIES

Re: magento 1.9 cart VAT only correct first view

Hi there. If this is only a problem once you've gone through the cart/checkout and set a shipping address, this probably is a configuration setting. This could be good news and bad news depending which way you look at it!

 

Things to check:

 

- Tax rules/zone

- Tax calculation settings

- Shipping Origin (for default tax calculation. 

 

What did you change to the cart when it started working?

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: magento 1.9 cart VAT only correct first view

Spoiler
If this is only a problem once you've gone through the cart/checkout and set a shipping address, this probably is a configuration setting

Exactly my thoughts.. (and thanks for the reply  ) And yeah it's only on and 'after' the cart page.

Re: magento 1.9 cart VAT only correct first view

As a temporary fix until i investigated things more i made clone of `Mage_Tax_Block_Checkout_Grandtotal`.

VERY dirty and i do NOT recommend anyone to use this. But i can now continue working on the site an hopefully resolve this issue later on.
Here my code (since my VAT is static always).

/**
     * Get grandtotal exclude tax
     *
     * @return float
     */
    public function getTotalExclTax()
    {

        $excl = $this->getTotal()->getAddress()->getGrandTotal()-($this->getTotal()->getAddress()->getGrandTotal()/121*21);//$this->getTotal()->getAddress()->getTaxAmount();
        $excl = max($excl, 0);
        return $excl;
    }