cancel
Showing results for 
Search instead for 
Did you mean: 

magento data flow import - no image selected in properties after upload

magento data flow import - no image selected in properties after upload

Hello together,

 

I have a question concerning the upload of images that slowly but steady drives me insane.

We are using Magento 1.9.2.4. The upload was successfull, all the images are linked to the right products.

 

However when I try to show the products in the shop, only placeholder images are shown for the configurable and the simple products (color variation), as in the properties the uploaded image is not selected as the one to show.

 

Instead 'No image' is selected for 'base image', small image' and 'thumbnail'.

 

Is there any way that I can tell magento during the upload process that the image I am uploading is the one that should be selected to show in the shop front end?

 

Thank you very much for your help!

 

Max

1 REPLY

Re: magento data flow import - no image selected in properties after upload

Hello Max,

Its a long time ago I used the Dataflow import (now using Mamgmi instead), but maybe below there is a solution.

First you have to create a CSV file with one product (and links to the images) to test it.

Then there are three options you can do.

Option 1:
You can check your Dataflow Profile at:

System->Import/Export->Dataflow Profiles

When you click at the one you use to import products, there is in the left screen a tab: 'profile actions XML'.
When clicking at this tab, then XML code is shown.
Look within the <action> tag (with method="parse") for the following line:

 

 

<var name="reimport_images"><![CDATA[true]]></var>


Make sure that this value is at true not at false.

When you dont see this line at all, you can add this between the <action> tag above.
In my version of Magento I can not add this line directly. I had to insert it into the database - the table name in the database is: dataflow_profile.

When you added this line, then let the profile run and fully complete and see what happens.

Option 2:
Maybe your import profile is missing something.

Under: System->Import/Export->Dataflow Advanced Profiles you can add a new profile.

Edit the code below to your needs and add this code under actions XML:

<action type="dataflow/convert_adapter_io" method="load">
    <var name="type">file</var>
    <var name="path">var/import</var>
    <var name="filename"><![CDATA[CHANGE_THIS.csv]]></var>
    <var name="format"><![CDATA[csv]]></var>
</action>
<action type="dataflow/convert_parser_csv" method="parse">
    <var name="delimiter"><![CDATA[,]></var>
    <var name="enclose"><![CDATA["]]></var>
    <var name="fieldnames">true</var>
    <var name="store"><![CDATA[0]]></var>
    <var name="number_of_records">1</var>
    <var name="root_catalog_id"><![CDATA[2]]></var>
    <var name="reimport_images"><![CDATA[true]]></var>
    <var name="deleteall_andreimport_images"><![CDATA[false]></var>
    <var name="exclude_images"><![CDATA[false]]></var>
    <var name="exclude_gallery_images"><![CDATA[false]]></var>
    <var name="decimal_separator"><![CDATA[.]]></var>
    <var name="adapter">catalog/convert_adapter_productimport</var>
    <var name="method">parse</var>
</action>


Upload your CSV file to test to the directory at the server: /var/import/

When this profile is saved, click at this profile to run it (under the tab: 'execute profile'). Let the profile fully complete and see what happens.

Option 3:
Use Magmi to import/change products instead of Magento Dataflow (it might lead to problems in the future). Magmi is much faster and easier to use. Its worth investing time in Magmi.

Hope this helps.

Greetings
Paravicini