cancel
Showing results for 
Search instead for 
Did you mean: 

"There has been an error processing your request" - Magento Community

"There has been an error processing your request" - Magento Community

Hi there ~

Sometimes when I enter the backend and frontend I get the error: "There has been an error processing your request" in Magento Community. Please tell me how I can fix it as soon as possible.

 

That's the log:

a:4:{i:0;s:48:"SQLSTATE[HY000] [2002] No such file or directory";i:1;s:3060:"#0 /home/familypharm/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(109): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/familypharm/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(320): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/familypharm/public_html/lib/Zend/Db/Adapter/Abstract.php(460): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/familypharm/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /home/familypharm/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(428): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element))
#7 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write')
#8 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write')
#9 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter()
#10 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(360): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter()
#11 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(134): Mage_Core_Model_Resource_Db_Abstract->getReadConnection()
#12 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Config.php(1348): Mage_Core_Model_Resource_Db_Collection_Abstract->__construct(Object(Mage_Core_Model_Resource_Website))
#13 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Config.php(1380): Mage_Core_Model_Config->getModelInstance('core_resource/w...', Object(Mage_Core_Model_Resource_Website))
#14 /home/familypharm/public_html/app/Mage.php(491): Mage_Core_Model_Config->getResourceModelInstance('core/website_co...', Object(Mage_Core_Model_Resource_Website))
#15 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Abstract.php(208): Mage::getResourceModel('core/website_co...', Object(Mage_Core_Model_Resource_Website))
#16 /home/familypharm/public_html/app/code/core/Mage/Core/Model/Abstract.php(213): Mage_Core_Model_Abstract->getResourceCollection()
#17 /home/familypharm/public_html/app/code/core/Mage/Core/Model/App.php(608): Mage_Core_Model_Abstract->getCollection()
#18 /home/familypharm/public_html/app/code/core/Mage/Core/Model/App.php(466): Mage_Core_Model_App->_initStores()
#19 /home/familypharm/public_html/app/code/core/Mage/Core/Model/App.php(349): Mage_Core_Model_App->_initCurrentStore('', 'store')
#20 /home/familypharm/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#21 /home/familypharm/public_html/index.php(87): Mage::run('', 'store')
#22 {main}";s:3:"url";s:76:"/all.html?dir=asc&limit=24&manufacturer=49&mode=grid&order=product_page_name";s:11:"script_name";s:10:"/index.php";}

 

Assistance would be appreciated, thanks! Smiley Happy

4 REPLIES

Re: "There has been an error processing your request" - Magento Community

Hi Raphael

 

It looks like either MySQL is not started on your server. Or are you pointing to a none existing socket.

 

 

Re: "There has been an error processing your request" - Magento Community

How do I fix this such of thing? (using FTP)

Re: "There has been an error processing your request" - Magento Community

Hi @Rephael 

 

If you don't have server access, you can't really start MySQL. But you can check the file app/etc/local.xml

 

If the host node is set to a point to a socket, check that this corrosponds with your server setup. If not try to set it to localhost or the db host specified by your hosting provider.

 

If none of this works, you should contact your hosting provider asking them for assistance in connecting to your MySQL database. The info you get from them you can enter in the local.xml file.

 

I hope this helps :-)

Re: "There has been an error processing your request" - Magento Community

Are you sure that's the problem? the only problem?