cancel
Showing results for 
Search instead for 
Did you mean: 

1.4.1.1 and 6788 patch. Core modules affected.

1.4.1.1 and 6788 patch. Core modules affected.

Hey,

 

I've been upgrading projects with the new patch and there's one 1.4.1.1 magento which after checking with this tool:

https://github.com/rhoerr/supee-6788-toolbox

 

found that many core modules like:

 

Mage/GoogleOptimizer

Mage/GoogleBase

Mage/Bundle

Mage/Compiler

Mage/Downloadable

 

need to be modified for patch to work.

 

So is there some other way of fixing this than modifying them?

 

Upgrade to later magento version is not possible.

 

Thanks.

10 REPLIES

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @Kaspars Liepa,

 

You need not to worry about core file modification (If you or any other third party which worked on your site has modified core files). 

The patch modifies the core file to keep the magento secure against the latest threats. 

 

I am also applying patch for Magento 1.4.11 today. I did not find  the following module changes

 

Mage/GoogleOptimizer
Mage/GoogleBase
Mage/Bundle
Mage/Compiler

 

in the files PATCH_SUPEE-6788_CE_1.4.1.1_v1-2015-11-04-05-11-44.sh

 

UPDATE : Later today I realized you are correct. This module (Mage/GoogleOptimizer) has been removed in the higher version{checked in Magento1.9.2.2 } of Magento .

 

Better if someone from Magento team can comment on this. @sherrie could you please help regarding this.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Checking on this from our end.

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Is there an update about this problem? I have no problems fixing core modules, but maybe there's going to be some patch or another way to do it "Magento way".

 

Thanks!

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @Kaspars Liepa

 

I am also waiting for any update on this as recently I have also applied patch for Magento 1.4.1.1 version and faced same issue as you faced.

As  @sherrie mentioned they are looking in to this issue. Till then we can wait and watch.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @Kaspars Liepa

 

Did you get any reply or update on this? 

Or you used some alternative approach to fix it?

 

Thanks

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hey!

 

No, I still haven't fixed it, but I assume I'll just fix the extensions myself by extending or localizing needed files. This is not urgent for me for now, but would be really nice to hear from Magento themselves, what is their solution.

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @Kaspars Liepa

 

I applied the patch on my production site after the module fixes. For a time period I have kept the "Admin routing compatibility mode for extensions" enabled.

 

I am not using compiler and other affected core module.I think this should be ok till the time we get reply from Magento.

 

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @muk_t & @Kaspars Liepa, I'm checking in on this for you.  I think we're updating this version of the patch but will let you know when I know for sure. Sorry for the delay!

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: 1.4.1.1 and 6788 patch. Core modules affected.

Hi @sherrie

 

Thanks for informing, no need to say sorry. I know Magento team is working on lot of projects now a days including new market place, Magento 2.0 etc. So it may take some time for this issue to get resolved.

 

We will wait for a solution by Magento.

Thanks

---
Problem Solved Click Accept as Solution!:Magento Community India Forum