cancel
Showing results for 
Search instead for 
Did you mean: 

7405 on Magento 1.4.1.1

7405 on Magento 1.4.1.1

Hello,

I am using magento 1.4.1.1 version i try to patch 7405 but can't be applied.

This PATCH is trying to add code on app/code/core/Zend/Xml/Security.php but app/code/core/Zend/Xml/ folder doesn't exist on version 1.4.1.1

 

 

 

8 REPLIES

Re: 7405 on Magento 1.4.1.1

 I have the same problem but then on 1.9.0.1

 

Security.php Not found

Re: 7405 on Magento 1.4.1.1

Hi @hristina_del & @Postitief, can you please verify that you downloaded the correct version of your patch for your version of Magento?

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: 7405 on Magento 1.4.1.1

Yes I have downloaded the patch for SUPEE-7405 for CE 1.9.0.0-1.9.0.1 (0.1 MB) and it tries to locate the file app/core/code/Zend/Xml/Security.php but the file is not there at all.

Re: 7405 on Magento 1.4.1.1 + 1.8.1

Hi,

 

I also found this error when I tried to apply the patch to CE version 1.8.1

 

can't find file to patch at input line 2168
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:

--------------------------
|diff --git app/code/core/Zend/Xml/Security.php app/code/core/Zend/Xml/Security.php
|index a3cdbc8..8b697b9 100644
|--- app/code/core/Zend/Xml/Security.php
|+++ app/code/core/Zend/Xml/Security.php
--------------------------

File to patch: 
Skip this patch? [y] 
Skipping patch.
3 out of 3 hunks ignored

Re: 7405 on Magento 1.4.1.1

You either did not apply SUPEE-6788 or had something go wrong when it was applied. Please check your app/etc/applied.patches.list and install all previous security patches in the order they were released.

 

The file in question => app/code/core/Zend/Xml/Security.php would have been created when you applied the SUPEE-6788 patch as is shown below from an excerpt from the 1.4.1.1 patch.

 

diff --git app/code/core/Zend/Xml/Security.php app/code/core/Zend/Xml/Security.php
new file mode 100644
index 0000000..a3cdbc8
--- /dev/null
+++ app/code/core/Zend/Xml/Security.php

It does not exist previous to applying this patch and not having it there is a pretty good indicator that SUPEE-6788 was never installed.  All security patches from February 2015 forward must be assumed to have dependencies on previous patches being installed.

 

Re: 7405 on Magento 1.4.1.1 + 1.8.1

Same goes for the failed 1.8.1.x failure, you are missing SUPEE-6788, therefore the file in question has not been applied. As further evidence, Magento will crash if  app/code/core/Zend/Xml/Security.php is missing as other patched files reference its existence.

Re: 7405 on Magento 1.4.1.1 + 1.8.1

Absolutely correct, @chiefair, the previous patch had not applied properly. I *don't think* that I have modified the .htaccess and .htaccess.sample files but it turns out that the former was not correct and the latter was not there. Perhaps this is because I originally installed from Softaculous or (more likely) maybe I moved the installation at the beginning and didn't do it properly.

 

Thanks for your help.

 

D.

Re: 7405 on Magento 1.4.1.1

Thanks this solved my problem after I applied the patch SUPEE-6788 I was able to apply SUPEE-7405 without problems.