cancel
Showing results for 
Search instead for 
Did you mean: 

8788 Questions

8788 Questions

Hi 

 

We have a number of website looking to update to the latest patch both on Community and Enterprise. Can you possible provide v1 on your website, as I have downloaded them from https://github.com/brentwpeterson/magento-patches

 

But on one site we already have 8788 v1 installed so how do we revert it? I have added the file to the htdocs folder but when I have tried running the file there is a syntax error. 

 

So I am completely lost at what to do. Also there is no information on the website for Enterprise 8788 patches.

 

Thanks,

16 REPLIES

Re: 8788 Questions

Open SSH and go to root folder where you patch is located (it should be in root folder). Now type:
sh PATCH_SUPEE-8788_CE_1.7.0.2_v1-2016-10-11-06-36-18.sh -R 
Your patch name could be different...

I assume your syntax error is on line 91, because to install V1 of patch you had to modify DashboardController file.... and now when you try to rever the patch it doesnt let you.... So you have to download original DashboardController file for your Magento version and Replace it.... then run the SSH command I added above.

 

Re: 8788 Questions

We have not been able to find the patch related SUPEE-8788 Can you direct me? or can you direct me to 1.9.3 upgrade?

Re: 8788 Questions

SUPEE 8788 VERSION 1 patches are no longer available. 

Version 2 patches you can find here
https://www.magentocommerce.com/download

Re: 8788 Questions

I'm sure there's a reason, though I can't imagine what. So, OK - that means I need to upgrade to 1.9.3 But I can't find those files either. Is there a problem with download files today or something? This is rather unusual.

 

Thanks for your help.

 

Re: 8788 Questions

There are no patches to download for 1.9.3 magento... it already has latest security fixes... If u need donwload 1.9.3 version of magento its available via the link i posted.. look carefully.

Re: 8788 Questions

I have noticed you said v1 patches are no longer available. But according to Magento on the download page it states the following:

 

  • Install SUPEE-3941 (if not installed yet) - that one makes sense
  • Revert SUPEE-1533 (if installed) - this is such an old patch why does this need to be reverted?
  • Revert SUPEE-8788 v1 - has already been installed. But as we use version control there would be no reason to keep the patch file in the repository we remove the file once it has been patched. Then commit those changes. But I have noticed that it says to revert v1. So what would the process to revert the patch.
  • Install SUPEE-8788 v2 - this once makes sense. Is there likely to be any updates or surprises, say a version 3 in the coming weeks? Also what is the current process with Enterprise Edition.

The reason I ask is that we have already applied a v1 patch as of last week, I have then installed 3941 as per the instructions. But then if we are using version control we remove the patch file, once the patch has been applied. I am just looking for a method which would allow me to revert the patch. Would the best way be to:

 

  • Place the v1 patch into the root folder
  • Run sh P command to execute the patch again
  • Then revert the Patch using the -R command
  • Then add and commit those changes

Would that be an okay process or could you recommend another way that we could do it? Because we have another site that is currently on v1.9.2.4 so it already contains v1. But we have installed v2, and currently on www.magereport.com it is not showing as patched even though it is listed in the applied patches file.

 

Thanks

Re: 8788 Questions

Upload 8788 v1 patch and do the sh -R command... then UNINSTAL 1533 and install 8788 v2

Re: 8788 Questions

I have tried to revert 8788 v1 but it does not seem to work. 1553 is not installed, but when I have tried to install 3941 its saying that it is already installed. I think it would be better to just install 8788 v2

 

 

Re: 8788 Questions

You have mentioned to upload v1. These are no longer available from Magento. Also I have looked on the applied patches list and 1533 is not listed. Also having trouble install 3941. Should I just install v2?