cancel
Showing results for 
Search instead for 
Did you mean: 

Error Installing Security Patches

SOLVED

Error Installing Security Patches

I am having trouble installing the two security patches SUPEE-5344 and SUPEE-1533

Using PuTTY with root access I keep getting this error:
"ERROR: "/root/app/etc/" must exist for proper tool work"

 

The directory app/etc exists in my magento installation so is there anything within this folder that might be missing?

Currently these files exist within the app/etc/ directory:

modules (directory)
.DS_Store
config.xml
local.xml
local.xml.additional
local.xml.template

 

My apologies if this is a novice question, I'm not very familiar with using SSH nor installing security patches.

Any help would be greatly appreciated.

40 REPLIES

Re: Error Installing Security Patches

 

Using PuTTY with root access I keep getting this error:
"ERROR: "/root/app/etc/" must exist for proper tool work"
 
The directory app/etc exists in my magento installation so is there anything within this folder that might be missing?

 

Hi Anthony,

 

It seems like you're running the patch from your homedirectory ("/root/"), and not from the folder where your Magento is installed. Try downloading the patch and running it from your main Magento folder, and it should install.

Re: Error Installing Security Patches

Brilliant! That was the problem, the patches have now applied successfully.

Thanks for your quick reply. Much appreciated!
Anthony.

Re: Error Installing Security Patches

Hi,

 

I have received the very same message from Magento and proceeded to Download the files.

However - this is kind of where my knowledge ends with Magento.

 

I can access my root directory - via Filezilla and CPanel.

 

But in terms of running the "folder where your Magento is installed. Try downloading the patch and running it from your main Magento folder, and it should install."

 

I honestly have no idea where that is.

 

My apologies also if this is a stupid question - but if anyone can point me in the right direction I would be most grateful.

Re: Error Installing Security Patches

I too am having this problem using Putty even though I am in the root directory of the installation.

Any ideas anyone?

 

Thanks in advance.

Re: Error Installing Security Patches

Hy, i've installed patch 5344, but now when i open magento homepage on my local installation, i see blank page.. 

I've installed Magento CE 1.9.1.0 and patch 5344 ( Magento-CE-v1.8.x-1.9.x (0.01 MB)).

What could be the problem?

Re: Error Installing Security Patches

As I try to install teh patch 5344 at 1.8 I recive this:

 

ERROR: Patch can't be applied/reverted successfully.
patching file app/code/core/Mage/Admin/Model/Observer.php
patching file app/code/core/Mage/Core/Controller/Request/Http.php
Hunk #2 succeeded at 537 (offset -4 lines).
patching file app/code/core/Mage/Oauth/controllers/Adminhtml/Oauth/AuthorizeController.php
patching file app/code/core/Mage/XmlConnect/Model/Observer.php
patching file lib/Varien/Db/Adapter/Pdo/Mysql.php
Hunk #1 FAILED at 2834.
1 out of 1 hunk FAILED -- saving rejects to file lib/Varien/Db/Adapter/Pdo/Mysql.php.rej

 

Can anybody help to solve it?

Re: Error Installing Security Patches

I'm haveing the same problem

Error: "/app/etc" must exist for proper tool work.

 

I am running it from the install folder...

I am using XAMPP, and trying to install the two patches in localhost.

Re: Error Installing Security Patches

Same problem Robot Mad

Re: Error Installing Security Patches

I don't know why Magento cannot offer an option of a zip file with the updated files.