cancel
Showing results for 
Search instead for 
Did you mean: 

Error when installing patch

SOLVED

Error when installing patch

Hello,

 

I'm trying to install patches SUPEE-5344 and SUPEE-1533, but getting the following error.  I'm on Ubuntu 14 and Magento CE 1.9.1.0.  Any suggestion would be appreciated.

 

============

line 7: $'\r': command not found

line 9: syntax error near unexpected token `$'{\r''

line 9: `_check_installed_tools() {

============

 

 

Shawn

11 REPLIES

Re: Error when installing patch

It's likely a line endings issue, sounds like your download method saved it with DOS based CRLF (\r\n) line endings instead of simple Linux LF newline (\n) that the file originally uses. It is after all a *nix shell script file. We can get away with allowing this to happen with PHP files, Shell scripts, not so much.

Re: Error when installing patch

Hi you cna cehckout difference if files for Magento 1.8.x-1.9.x . I have it on the GitHub. Hope it would help you to patch in case SSH will  not work for you.

Re: Error when installing patch

Hello, simply just put the file in its magento?

Re: Error when installing patch

Hi

The last revision it's original core files which was patched

Re: Error when installing patch

After you replace the file it's good? However I have a concern with my way (downloader). When I do http://mondomaine.com/downloader it gives me this: SQLSTATE[08004] [1040] Too many connections.

 

If I understand correctly I connect too many times to my /downloader?

Re: Error when installing patch

Hi,

No its issue with database. Seems like there a limit for connections to database. Please contact hosting provider with this issue

Re: Error when installing patch

I was able to install the patches by following sashas777's post.

 

Shawn

Re: Error when installing patch

Hello

 

After install of patch I started getting error in admin url when log out and after cannot log in. 

 

Fatal error: Call to undefined method Mage_Core_Controller_Request_Http::getInternallyForwarded() in /home/xxxxx/public_html/includes/src/Mage_Admin_Model_Observer.php on line 76

 

Could someone help me?

Thank you.

Re: Error when installing patch

I had the same problem. Downloaded the patches with a mac and via ftp to the server. Results in the problems.

Then I downloaded the patches with a windows system and uploaded them. Patched successfully!