cancel
Showing results for 
Search instead for 
Did you mean: 

Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

I applied the SUPEE-10415 patch for magento version CE 1.9.3.2, and in the installation via ssh I noticed that there were no lines and files, and the magento validator accuses me of not having installed the patch. What should I do ?

5 REPLIES

Re: Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

Hi @jazielmatoso,

 

Can you explain what it means "I noticed that there were no lines and files"?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

If you download the magento magento version CE 1.9.3.2 and apply the SUPEE-10415 patch for the same version (1.9.3.2), there will be lines in magento files that the patch will not find, for example:

if you open the file: app / code / core / Mage / Adminhtml / Model / LayoutUpdate / Validator.php of CE version 1.9.3.2 in magento


and open the file PATCH_SUPEE-10415_CE_1.9.3.2_v1-2017-11-28-06-38-23.sh
we will see that the patch makes a modification to line 142 of this file (app / code / core / Mage / Adminhtml / Model / LayoutUpdate / Validator.php)

- if (strpos ($ path, '../')! == false) {
+ if (strpos ($ path, '..'. DS)! == false) {
                  throw new Exception ();
              }


but this line does not exist in the original file of magento CE 1.9.3.2. This and other files that are also in the same form. What should I do?

Re: Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

Hi @jazielmatoso,

 

It seems like a patches problem (I guess).

Can you check all patches/dependencies are ok?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

They are.What should I do now? Any idea?

 
 
 
 

Re: Instalation SUPEE-10415 patch for magento version CE 1.9.3.2 not have success

Hi @jazielmatoso,

 

No ideas right now. Did you checked this thread? https://magento.stackexchange.com/questions/203567/security-patch-supee-10415-possible-issues

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"