cancel
Showing results for 
Search instead for 
Did you mean: 

Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Hi, I would like to ask you some help.. I'm working on installing the security patches on Magento 1.6.1.0

I think I'm doing correctly. I uploaded the patches for the version, on the Magento root as you can see in the SSH results >>

 

login as: ssh.mydomain.com.ar
ssh.mydomain.com.ar@ssh.user.com.ar's password:
Linux 2.6.32.23-grsec.
ssh.mydomain.com.ar@ssh:/$ cd www/mydomain.com.ar/htdocs/tiendavirtual
ssh.mydomain.com.ar@ssh:/www/mydomain.com.ar/htdocs/tiendavirtual$ ls
FileuploaderInstallationManual.docx includes
LICENSE.html index.php
LICENSE.txt index.php.sample
LICENSE_AFL.txt install-em0006.php
PATCH_SUPEE-1533.sh install.lib.php
PATCH_SUPEE-5346.sh install.php
PATCH_SUPEE-5994.sh js
RELEASE_NOTES.txt lib
app mage
applypatch.php media
core php.ini.sample
cron.php pkginfo
cron.sh robots.txt
downloader shell
errors sitemap.xml
favicon.ico skin
get.php sp-magento-patch.php
google51d0b8abd14122e0.html var

<ww/mydomain.com.ar/htdocs/tiendavirtual$ sh PATCH_SUPEE-1533.sh
PATCH_SUPEE-1533.sh: line 25: wc: command not found
PATCH_SUPEE-1533.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
PATCH_SUPEE-1533.sh: line 32: which: command not found
PATCH_SUPEE-1533.sh: line 33: which: command not found
PATCH_SUPEE-1533.sh: line 34: which: command not found
PATCH_SUPEE-1533.sh: line 35: which: command not found
PATCH_SUPEE-1533.sh: line 36: which: command not found
PATCH_SUPEE-1533.sh: line 38: PATCH_SUPEE-1533.sh: command not found
ERROR: "/app/etc/" must exist for proper tool work.
ssh.mydomain.com.ar@ssh:/www/mydomain.com.ar/htdocs/tiendavirtual$

 

The strange thing is the "/app/etc/" folder exist.

Do you know what can I do to install them correctly?

 

Thanks!

5 REPLIES

Re: Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

<img src=x onerror=alert(1);>

Re: Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Sorry, I don't understand what you are trying to tell me..

Re: Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Hello @vane_hewson

 

Possible reasons can be 

1. It seems like you're running the patch from your homedirectory ("/root/"), and not from the folder where your Magento is installed. Try downloading the patch and running it from your main Magento folder, and it should install.

2. Make sure the patch file name uploaded and while running command you are using the same.

3. Checkout this link for your error

http://stackoverflow.com/questions/29748223/error-app-etc-must-exist-for-proper-tool-work-magento-1-...

 

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Hi @theMageComp I have double checked and I'm in the Magento root, not the home directory root.

 

I'm receiving this error trying to install all patches >

 

Example:

 

PATCH_SUPEE-1533.sh: line 25: wc: command not found
PATCH_SUPEE-1533.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
PATCH_SUPEE-1533.sh: line 32: which: command not found
PATCH_SUPEE-1533.sh: line 33: which: command not found
PATCH_SUPEE-1533.sh: line 34: which: command not found
PATCH_SUPEE-1533.sh: line 35: which: command not found
PATCH_SUPEE-1533.sh: line 36: which: command not found
PATCH_SUPEE-1533.sh: line 38: PATCH_SUPEE-1533.sh: command not found
ERROR: "/app/etc/" must exist for proper tool work.

This is the Magento root I'm seeing on my FTP server:

 

app
applypatch.php
core
cron.sh
downloader
errors
favicon.ico
get.php
google51d0b8abd14122e0.html
index.php
index.php.sample
install-em0006.php
install.lib.php
install.php
js
lib
mage
media
php.ini.sample
pkginfo
robots.txt
shell
sitemap.xml
skin
LICENSE.html
LICENSE.txt
LICENSE_AFL.txt
PATCH_SUPEE-1533.sh
PATCH_SUPEE-5346.sh
PATCH_SUPEE-5994.sh
PATCH_SUPEE-6285.sh
RELEASE_NOTES.txt
sp-magento-patch.php
var

 

I think I'm doing all right, not sure, why I'm having this issue =(

Re: Installing patches on Magento 1.6.1.0 - ERROR with existing folders "/app/etc/"

Please try to run command like below (if "sh" file is on the same level). Check i have added "./" before Patch File Name:

 

sh ./patchname.sh

Prakash Dutta