cancel
Showing results for 
Search instead for 
Did you mean: 

Is v2 SUPEE-6285 patch needed if not using RWD theme?

SOLVED

Is v2 SUPEE-6285 patch needed if not using RWD theme?

I've updated all our installs with the SUPEE-6285 patch v1. I've now seen the notification where we need to revert v1 and then patch with v2.

 

This is just to patch for the rwd responsive theme correct? What if we don't use that theme? Is it necessary to patch it (we have several installs and trying to save some time if we're not using it). I gather this since we don't have to do this revert/re-patch for older Mage versions that don't have that theme.

 

Lastly, since this is something that is needing patching at a theme level, would there be concerned for other themes (commercial, free, custom themes)? Generally I would assume this is core Magento patches to fix vulnerabilities. I wouldn't expect themes to have vulnerabilities.

 

Thanks

2 REPLIES

Re: Is v2 SUPEE-6285 patch needed if not using RWD theme?

Technically, no, but often software exploits involve regression errors like this where somebody forgets about the issue and enables something later on.

 

It's very easy to fix this by manually editing the template in question and overwriting the file. See initial post in this thread =>

 

http://community.magento.com/t5/Technical-Issues/magento-patch-6285-v2/m-p/10609

 

Remove the - (minus line) and replace with the + (plus line) and that's ALL the misery of revert Version 1 and apply Version 2 does.

Re: Is v2 SUPEE-6285 patch needed if not using RWD theme?

Awesome.. thanks for the advice. Will take care of this.