cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9.0.1 - Error after applying patch SUPEE-6788

SOLVED

Magento 1.9.0.1 - Error after applying patch SUPEE-6788

Hi,

 

I applied security patch 6788 to my Magento website, but it cause the following error and my website doesn't work anymore :

Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.`value)` = '0') AND (`start_time` = '2016-05-' at line 2";i:1;s:4966:"#0 /lib/Varien/Db/Statement/Pdo/Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)

 

Therefore, i revert it and my website is working but it still vulnerable !!!

 

Moreover, I can't apply patch 6788 and 7405.

 

Does someone have a solution ?

 

Thanks

1 REPLY

Re: Magento 1.9.0.1 - Error after applying patch SUPEE-6788

Hi @ghislainabccom

 

Modify your custom modules according to this documentation SUPEE-6788 TECHNICAL DETAILS

Check this section APPSEC-1063, addressing possible SQL injection

---
Problem Solved Click Accept as Solution!:Magento Community India Forum