cancel
Showing results for 
Search instead for 
Did you mean: 

Magento and PHP version

Magento and PHP version

Is it safe to run 1.7.0.2 magento and php version of 5.3.3 ?  All Magento patches are installed.

If not safe, what is the recommended safest php version to run on 1.7.0.2 ?

2 REPLIES

Re: Magento and PHP version

It's not a question about Magento: any PHP version older than 5.6 are at the time of writing this post deprecated, which means that they are inherently insecure. So If you want to feel 100% safe, use PHP 5.6 or newer. To find out which versions of PHP are deprecated, check here: https://en.wikipedia.org/wiki/PHP

 

Tanel Raja

Re: Magento and PHP version

Thanks for replying! I did read some threads and noticed that on 1.7 Magento, PHP 5.6 may or may not work great. I am wondering how critical is it to switch from 5.3 php ?

 

It seems many magento stores are still running 5.3, perhaps its most compatible with most extensions and overall magento 1.7 operations. Upgrading to 1.9 for great 5.6 compatibility is lots of work.

 

Any thoughts?