cancel
Showing results for 
Search instead for 
Did you mean: 

PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

SOLVED

PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Having an issue applying the patch to a recent install of CE 1.9.1.1. the only change so far is that SUPEE-5344 is already instaled.

[root@servername httpdocs]# ./PATCH_SUPEE-5994_EE_1.14.1.0_v1-2015-05-14-05-05-02.sh
Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.

patching file app/code/core/Mage/Authorizenet/controllers/Directpost/PaymentController.php
patching file app/code/core/Mage/Core/Controller/Varien/Router/Admin.php
patching file app/code/core/Mage/Core/Controller/Varien/Router/Standard.php
patching file app/code/core/Mage/Customer/Model/Customer.php
patching file app/code/core/Mage/Dataflow/Model/Convert/Parser/Csv.php
patching file app/code/core/Mage/ImportExport/Model/Export/Adapter/Csv.php
patching file app/code/core/Mage/Install/Controller/Router/Install.php
patching file app/code/core/Mage/Install/etc/config.xml
patching file app/code/core/Mage/Sales/controllers/Recurring/ProfileController.php
patching file downloader/Maged/Model/Connect.php
patching file downloader/Maged/View.php
patching file downloader/template/connect/packages_prepare.phtml
patching file downloader/template/messages.phtml
patching file get.php
Hunk #1 succeeded at 36 (offset -1 lines).
can't find file to patch at input line 347
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git lib/PEAR/PEAR/PEAR.php lib/PEAR/PEAR/PEAR.php
|index b4633bf..e6f8edc 100644
|--- lib/PEAR/PEAR/PEAR.php
|+++ lib/PEAR/PEAR/PEAR.php
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
42 out of 42 hunks ignored
patching file lib/PEAR/PEAR/PEAR5.php
patching file lib/Varien/Io/File.php

 

 

Tags (1)
14 REPLIES

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

For one customer I have the exact same error on the exact same line. There is no core modification present in this webshop. Two other webshops with the same 1.9.1.0 version had no issues when I applied the patch.

Looking into the patch file line 347 seems to apply to an enterprise edition file but I might be wrong.

All file permissions are correct so I'm out of clues how to apply this fix for this customer.

Anyone?

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Getting the exact same issue with EE1.13.10 (using the EE patch)

 

Tried on 3 different dev environments, ubuntu, rhel, 5 different test evironments and 1 staging environment. Same issue. So don't think it's based on OS/distribution.

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Hasnt fixed the issuse here.

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Hi @shane242, are you saying you installed patch SUPEE-5344 after installing 1.9.1.1? If so, that may be the issue as SUPEE-5344 was part of the 1.9.1.1 release.

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Thanks for the reply Sherrie,

 

The site was installed as 1.9.0.1 and patched with SUPEE-5344 previously before updating to 1.9.1.1.

 

Though im having the same issue with a completly fresh copy of 1.9.1.1.

 

The issue is when trying to patch SUPEE-5994 seems to fail due to the following directory not existing

lib/PEAR/

 

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Hi @shane242

 

We have updated our blog which will guide you installing SUPEE 5994: http://magecomp.com/blog/how-to-install-magento-security-patches/#SUPEE5994

 

Let me know if you are still having the issue. 

 

SECURITY DISCLAIMER: The above website contains Magento Security Patch files which are self-hosted by the user and as such unsafe. Magento Forum advise all users to only download patch files from the official Magento Downloads page. 

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Thanks,

 

I completed the install by uploading a copy of the missing "lib/PEAR/PEAR/PEAR.php" file from another copy of Magento (originally 1.8**), then running via the standard SSH method with the updated PATCH_SUPEE-5994_CE_1.6.0.0_v1-2015-05-15-04-34-46.sh patch file from the download area.

 

Not sure why neither my 1.9.0.1 or the 1.9.1.1 sites have the file, yet is required by the patch.

Re: PATCH_SUPEE-5994 - ERROR: Patch can't be applied/reverted successfully.

Thanks for updating @shane242, glad you got it sorted! Will pass along your findings!

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical