cancel
Showing results for 
Search instead for 
Did you mean: 

PATCH SUPEE-6285 not working?

SOLVED

PATCH SUPEE-6285 not working?

Anyone else having problems getting the newly released patch to work?  I'm running Magento 1.9.1.0, but it's fully patched up to this most recent patch.  I just verified by doing a dry-run patch with SUPEE-5994 to ensure that it was already done.

 

When I try to run the SUPEE-6285 patch, I get the following:

./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 14: ./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 127: not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 14: ./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 127: not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 25: ./PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-07-09-03-34.sh: 0: not found
Checking if patch can be applied/reverted successfully...
-e ERROR: Patch can't be applied/reverted successfully.

 Lines 14 and 25, where the script appears to be having issues, are in the function _check_installed_tools(), so perhaps I'm missing a tool on our server to do the patch.  But there isn't any relevant error message to indicate which tool.

 

A little help please?

8 REPLIES

Re: PATCH SUPEE-6285 not working?

Looked through some old threads and found the solution.  There was a file that already exists that the script wished to create.  I didn't inlcude the full output from the failure of the patch, but these lines were included and important:

The next patch would create the file downloader/Maged/.htaccess,
which already exists!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored

Turns out I just had to remove the downloader/Maged/.htaccess file and then the patch installed without any problems.

Re: PATCH SUPEE-6285 not working?

Thanks for the post, I'm in testing phase and will report any other silliness I come accross.

Re: PATCH SUPEE-6285 not working?

Hi,

 

I have applied recent security patches and finding that PATCH_SUPEE-6285 is failing on one file which is AuthorizeController.php.

 

patching file app/code/core/Mage/Oauth/controllers/Adminhtml/Oauth/AuthorizeController.php
Hunk #1 FAILED at 298.
1 out of 1 hunk FAILED -- saving rejects to file app/code/core/Mage/Oauth/controllers/Adminhtml/Oauth/AuthorizeController.php.rej

 

I have Magento ver 1.7.0.2 installed and I downloaded the following security patches

 

PATCH_SUPEE-5345_CE_1.7.0.2_v1-2015-02-10-08-11-22 (Applied in February)

PATCH_SUPEE-5994_CE_1.6.0.0_v1-2015-05-15-04-34-46 (Applied in May - note this patch is for magento versions 1.6.0.0 til 1.9.1.1)

PATCH_SUPEE-6285_CE_1.7.0.2_v1-2015-07-07-09-09-08 (Failed)

 

Existing lines 294 - 301 in file app/code/core/Mage/Oauth/controllers/Adminhtml/Oauth/AuthorizeController.php are as below;

 

294       /**
295       * Reject token authorization simple page
296       */
297       public function rejectSimpleAction()
298       {
299       $this->_initRejectPage();
300      }
301      }

 

Anyone with any idea as to why this is occuring?

 

Thanks,

 

DR

Re: PATCH SUPEE-6285 not working?

I had the same issue and removing that file allowed it to patch successfully, but why does the scrip just assume no without prompting the user for input?

Re: PATCH SUPEE-6285 not working?

Hello, we have written quickly a tiny tool to check a bit more ...

 

https://www.clever-zoeger.de/blog/magento/magento-patch-supee-6285-security-patch-extended-check.htm...

 

feel free do give us feedback if do you think it makes sence :-)

you are welcome to improve our code as well.

Re: PATCH SUPEE-6285 not working?

Thanks for your reply, but that didn't do it either, the patch still can't be applied as that file is now missing!

Re: PATCH SUPEE-6285 not working?

The hunk failure is probably due to a line ending issue. Others have fixed it by downloading the full install archive of their version, extracting the file that has the hunk failure and uploading it to their Magento installation where they're trying to apply the patch.

 

In your case this would be app/code/core/Mage/Oauth/controllers/Adminhtml/Oauth/AuthorizeController.php that you want to extract.

 

https://www.magentocommerce.com/download and click the Release Archive tab to access full Magento install archives for past versions.

 

Re: PATCH SUPEE-6285 not working?

Hi guys,

to resolve this problem, comment the 2 lines below in the file PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-10-08-10-09.sh:

#--- app/design/frontend/default/modern/template/checkout/cart.phtml
#+++ app/design/frontend/default/modern/template/checkout/cart.phtml

 

thanks