cancel
Showing results for 
Search instead for 
Did you mean: 

Patch applied, now some admin links broken

Patch applied, now some admin links broken

Hi

 

I'm not sure if these are related, but a colleague installed the patch this morning, and now we have some, but not all, broken admin links. For example, Manage Categories works, Manage Products leads to Oops we have a problem on the front end. Does this sound like something went wrong with patch installation?

 

Very sorry for vague questions but don't really know where to start on this one.

Tags (2)
2 REPLIES

Re: Patch applied, now some admin links broken

If you have the compiler enabled, have you recompiled?

Clear the Magento cache.

 

Log out of the Magento backend and then back in.

 

Clear opcode caching if you are running apc cache or opcache.

 

Mentioning the above bacause they're often overlooked. Installing patches is just like installing modules which works best if the following mantra is chanted, the elementals are invoked and many bottles of magica replenishment quaffed.

 

Disable Compiler and Magento Cache before installation. Log into backend, log back out, log back in, clear Magento Cache. Test function, then reenable Magento Cache, test function again. Recompile and then reenable compiler, if website goes TU, disable compiler with shell/compiler.php and dispose of using compiler.

 

Re: Patch applied, now some admin links broken

Thank you for the suggestions!

 

Actually we were "lucky" in that we had two test sites which had also been patched but on one of them it was still working, so we were able to compare and contrast. Turns out that on one of the test sites a certain extension had been uninstalled and this was the one that was causing the problems on the live siteso we were able to work from there.