cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with choosing patches

Problem with choosing patches

Hi Guys,

I am the co owner of a little magento webshop and for lack of real developers in charge of the IT management (i am actually a UX designer).

 

We are running a older version (1.7.0.2). I am currently looking to install the security patches that were brought out last year (we have updated since installing).

 

I am however lost on which updates i need to install (the magento patch page has so many and the documentation is directed to people who know what they're doing...) Do newer updates include older patches? If not, what are the must-have patches that i need to get?

 

If anybody can help me with this that would be really helpful.

2 REPLIES

Re: Problem with choosing patches

Magento patches are not cumulative.

 

Each patch needs to be applied in the order it was released, especially later versions that have dependencies on previous patches being applied before they can be applied.

 

The site seems to do a reasonable job keeping them in chronological order, start at the bottom of the page and work your way up.

 

Check for a file in app/etc/ named applied.patches.list that will show you what should have already been applied, start where it leaves off.

Re: Problem with choosing patches

THank you for your reply, this helped with my understanding of the issue Smiley Happy