cancel
Showing results for 
Search instead for 
Did you mean: 

Risk in not rolling back Patch 6285?

SOLVED

Risk in not rolling back Patch 6285?

Hello,

 

On the server we have, we do not have access to SSH, and rolling back the patch has become a little bit of a task. Is there any way I could possibly manually change whatever is different from v1 to v2? or should I just bypass and patch up to 6482, with 6285 v1 still intact? Thanks!

 

5 REPLIES

Re: Risk in not rolling back Patch 6285?

Which version are you on @WinteRx182?

 

The patch for 1.9.0.0-1.9.1.1 only was missing the following change in app/design/frontend/rwd/default/template/checkout/cart.phtml:

 

Remove    <button type="button" title="<?php echo $this->__('Continue Shopping') ?>" class="button2 btn-continue" onclick="setLocation('<?php echo $this->getContinueShoppingUrl() ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>
Replace    <button type="button" title="<?php echo $this->quoteEscape($this->__('Continue Shopping')) ?>" class="button2 btn-continue" onclick="setLocation('<?php echo Mage::helper('core')->quoteEscape($this->getContinueShoppingUrl()) ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>

 

Credit to @chiefair for sharing this here: http://community.magento.com/t5/Technical-Issues/magento-patch-6285-v2/m-p/10603/highlight/true#M250...

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Risk in not rolling back Patch 6285?

@sherrie That might've sounded a little confusing, I agree. lol

 

My current last update was "SUPEE-6285 | CE_1.9.1.1 | v1", then I noticed on the patch page that it states "Note: if you have previously applied patch PATCH_SUPEE-6285_CE_1.9.1.1_v1, please revert it and apply PATCH_SUPEE-6285_CE_1.9.1.1_v2."

 

Having no access to SSH, and only using a restricted process of using a cronjob to apply the patch (not ideal of course), makes it tough to revert the patch. So my main question was if it is a risk bypassing going to v2 and just applying patch 6482 on top of 6285 v1. Or if there would be a way to manually *apply* patch v2 by doing the changes on my own, which I believe might be what you just posted above. 

 

Just looking for the clarification so I can proceed, thanks so much!

Re: Risk in not rolling back Patch 6285?

Okay, so in your situation you need to follow the instructions I mentioned above and then you'll essentially have the v2 patch.

 

In app/design/frontend/rwd/default/template/checkout/cart.phtml, 

 

1. Remove this code snippet: 

 

<button type="button" title="<?php echo $this->__('Continue Shopping') ?>" class="button2 btn-continue" onclick="setLocation('<?php echo $this->getContinueShoppingUrl() ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>


2. Replace it with this:

 

<button type="button" title="<?php echo $this->quoteEscape($this->__('Continue Shopping')) ?>" class="button2 btn-continue" onclick="setLocation('<?php echo Mage::helper('core')->quoteEscape($this->getContinueShoppingUrl()) ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>
--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Risk in not rolling back Patch 6285?

Excellent, thank you!

Re: Risk in not rolling back Patch 6285?

Happy to help, @WinteRx182. Smiley Happy

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical