Whether SUPEE-10415 is mandatory to install in magento CE 184.108.40.206? whether previous patches are necessary to be installed?can we install this patch with PHP 5..3 version?
Yes, SUPEE-10415 needs to be installed for Magento CE 220.127.116.11 as well.
You can find the patch on the download page here: https://magento.com/tech-resources/download (go to "Release Archive" and scroll down to "Magento Open Source Patches - 1.x" where you will find the download for 18.104.22.168 in the dropdown).
All previous patches need to be applied as well.
As Magento CE 22.214.171.124 is compatible with PHP 5.3 I would assume the patch is compatible as well.
Anyway, I would recommend to update your PHP version as well. It is not safe to run PHP 5.3 since it does not get security fixes for over two years already. There is a special patch for PHP 5.4 support (at least).
It's on the same download page as well.
PHP 5.4 - Support for PHP 5.4 - Added Jan 17, 2014