cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE 5994 Built In FAIL for 1.6.x.x

SOLVED

SUPEE 5994 Built In FAIL for 1.6.x.x

Everything almost works except when you read the installed.patches.list and come accross this little item. First it patches a file that does not exist and then proceeds to add reference to it in the config.xml file. Hmm, good one when it attempts to load the missing file...

 

From installed patches.list, the following:

 

patching file app/code/core/Mage/Install/Controller/Router/Install.php
patching file app/code/core/Mage/Install/etc/config.xml

 

Reference added to the config.xml for the file that doesn't get created.

 

>     <default>
>         <web>
>             <routers>
>                 <install>
>                     <area>frontend</area>
>                     <class>Mage_Install_Controller_Router_Install</class>
>                 </install>
>             </routers>
>         </web>
>     </default>
>     <stores>
>         <default>
>             <web>
>                 <routers>
>                     <install>
>                         <area>frontend</area>
>                         <class>Mage_Install_Controller_Router_Install</class>
>                     </install>
>                 </routers>
>             </web>
>         </default>
>     </stores>

When you read the diff file (starting point below) you find that it's trying to create this file, but due to the Router folder not preexisting in app/code/core/Mage/Install/Controller, not only is the folder not created, but the file it's supposed to contain never gets created.

 

diff --git app/code/core/Mage/Install/Controller/Router/Install.php app/code/core/Mage/Install/Controller/Router/Install.php

2 REPLIES

Re: SUPEE 5994 Built In FAIL for 1.6.x.x

NOTE: This was done on a development server and the files rolled back to pre-patch installation versioning.

 

Use your sftp client to create the following path to its full extent.

 

app/code/core/Mage/Install/Controller/Router

 

When you run the patch file, it will add the Install.php file to the Router folder

 

<?php
/**
 * Magento Enterprise Edition
 *
 * NOTICE OF LICENSE
 *
 * This source file is subject to the Magento Enterprise Edition End User License Agreement
 * that is bundled with this package in the file LICENSE_EE.txt.
 * It is also available through the world-wide-web at this URL:
 * http://www.magento.com/license/enterprise-edition
 * If you did not receive a copy of the license and are unable to
 * obtain it through the world-wide-web, please send an email
 * to license@magento.com so we can send you a copy immediately.
 *
 * DISCLAIMER
 *
 * Do not edit or add to this file if you wish to upgrade Magento to newer
 * versions in the future. If you wish to customize Magento for your
 * needs please refer to http://www.magento.com for more information.
 *
 * @category    Mage
 * @package     Mage_Install
 * @copyright Copyright (c) 2006-2014 X.commerce, Inc. (http://www.magento.com)
 * @license http://www.magento.com/license/enterprise-edition
 */

class Mage_Install_Controller_Router_Install extends Mage_Core_Controller_Varien_Router_Standard
{
    /**
     * Check if current controller instance is allowed in current router.
     * 
     * @param Mage_Core_Controller_Varien_Action $controllerInstance
     * @return boolean
     */
    protected function _validateControllerInstance($controllerInstance)
    {
        return $controllerInstance instanceof Mage_Install_Controller_Action;
    }
}

 

Re: SUPEE 5994 Built In FAIL for 1.6.x.x

This explanation makes sense to me, except in my case it is not what happened...

 

I'm running 1.7.x.x

 

After the patch I had this same issue.

I tried the compilation disable, clear, compile, enable idea but still got the same result.

BUT if I disable compilation now, all works fine, until I try compiling again.

 

The thing is, that install.php file was created by my patch process and it looks as it should.

It seems to be more the case that my config doesn't know where to look for it.

 

Any ideas?

I'd really like to turn compilation back on because my template has a horrific number of files :-(

 

thanks