cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-5994 Patch for CE 1.4.2.0?

SOLVED

SUPEE-5994 Patch for CE 1.4.2.0?

So far i can only download SUPEE-5994 for CE 1.4.1.0 - 1.4.1.1, 1.5.0.1, 1.5.0.1 - 1.5.1.1 and 1.6.0.0 - 1.9.1.1.

 

Is there a Patch for Version CE 1.4.2.0?

 

Thank you.

5 REPLIES

Re: SUPEE-5994 Patch for CE 1.4.2.0?

*push*

 

Anyone using CE 1.4.2.0? Can i use the patch-file 1.4.1.0 - 1.4.1.1?

Re: SUPEE-5994 Patch for CE 1.4.2.0?

While we are waiting for an official answer to this (which we will probably never get ^^) I made some own research which humble result I would like to share with you.

 

Which patch to take 1.4.1.1 or 1.5.0.1 when running 1.4.2.0?

Basically the patch for the both versions is the same, with the difference that the patch for 1.5 contains some additional fixes in the following files:

  • app/code/core/Mage/Authorizenet/controllers/Directpost/PaymentController.php
  • app/code/core/Mage/ImportExport/Model/Export/Adapter/Csv.php
  • downloader/Maged/Model/Connect.php
  • downloader/Maged/View.php
  • downloader/template/connect/packages_prepare.phtml

The only file of these, that even exists in 1.4 is downloader/Maged/View.php. Which IMHO means that you won't gain anything in installing the 1.5 patch on 1.4, while it also theoretically shouldn't break anything.

 

Based on the above I decided to use the 1.4.1.1 patch and deployed it to live after some testing. So far everything seems to work.

Re: SUPEE-5994 Patch for CE 1.4.2.0?

Hello

I 'm looking to install the patch 5994 but I have the version 1.7.0.2.

 

I don't not how i can do that ?

Re: SUPEE-5994 Patch for CE 1.4.2.0?

Hey,
if you don't have SSH access (I suppose if you'd have SSH access you would know how to use it to apply the patch) the easiest way is to follow this installation instruction. Just download the (unofficial!) package for your version linked there and upload the files.

Re: SUPEE-5994 Patch for CE 1.4.2.0?

Thank you m_witt for your analysis!