cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-5994 appears to patch nothing on magento 1.7.0.2

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2

several of my installs don't even have lib/PEAR, but some do. Am I supposed to have that? Should I add them just so I can run the patch properly?

How to Apply and Revert Magento Patches

First of all thank you for all using the forum . 

 

I see that some of you have used the wrong patch for the wrong Magento versions if you have given the correct information here in the post.

 

Its absolutely important that you have the right patch for the right version. Also that any patches is downloaded from Magentos Official download page : https://www.magentocommerce.com/products/downloads/magento/

 

 

For information on how to Apply and Revert Magento Patches and also Troubleshooing please see the documentation made by Magento.

 

http://devdocs.magento.com/guides/m1x/other/ht_install-patches.html

Re: How to Apply and Revert Magento Patches

i agree, correct patches need to be applied to the correct version. but in my case, I downloaded the correct version, tried to apply it and it failed. on all instances. and no core code or folder structure had been changed. in the end, it worked with a patch for a different version - according to the official download page.

 

at the same time, since we're discussing patches, the naming convention is quite frustrating. when I try to see what patches I've applied they don't match the main patch identifier. take this last patch for example, instead of supee-5994 (or whatever number it has), my magento shows supee-6016 which is very confusing.

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2 & CE 1.8.1.0

For those without a downloader folder, what did you do to solve this? 

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2 & CE 1.8.1.0

The solution to install correctly the patch 5994 : 

 

1 - Open the patch 5994 file with textedit or notepad.

2 - Search for the word "downloader" in the code

3 - Change the name of the directory "downloader"  with the real name on your server "downloader_fh0******". 

Exemple : change downloader/Maged/Model/Connect.php   to   downloader_fh0******/Maged/Model/Connect.php

This has been changed recently in order to avoid someone from outside to take control of the directory.

4 - Save your file and upload it to your server.

5 - Apply the patch.

 

Kind regards, 

Marc.

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2

For all trying to install the 5994 patch having error on lib/PEAR/PEAR/PEAR.php file, because the whole lib/PEAR folder does not exist in their installation: it seems that if installing Magento from the downloader, this folder is not installed.

In order to be able to install the patch, you should copy in your Magento installation the lib/PEAR folder taken from the original Magento installation package of your version.

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2 & CE 1.8.1.0

Hello,

 

Can anybody please confirm the latets version of the magento community extension already have updated the security patch Smiley FrustratedUPEE-5994

 

Regards

Pankaj

Certified Magento Developer Plus

Skype: erpankajgupta06

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2

Hello,

 

Can anybody please confirm the latets version of the magento community extension already have updated the security patch Smiley FrustratedUPEE-5994

 

Regards

Pankaj

Certified Magento Developer Plus

Skype: erpankajgupta06

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2

No, it hasn't been, you will need to install the SUPEE-5994 patch.

Was my answer helpful? You can accept it as a solution.
150+ professional extensions for M1 & M2 with free lifetime updates!

Re: SUPEE-5994 appears to patch nothing on magento 1.7.0.2 & CE 1.8.1.0

Very helpful.... This was the issue on my end as well.