cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

Hi,

 

today I applied the two security patches 7405 and 7616.

After successfully applying them, my site broke down. The only thing that is shown is the PHP fatal error message: Class 'Zend_Xml_Security' not found in /var/www/html/sitename/lib/Zend/Locale/Data.php on line 160.

 

The file Security.php under lib/Zend/Xml/ folder exists.

 

Anyone has the same issue? How could I bring my site back to life?

4 REPLIES

Re: SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

Same probleme for me with the patch 7405

Fatal error: Class 'Zend_Xml_Security' not found in /var/www/html/genericdev/lib/Zend/Locale/Data.php on line 164

but the file exist in lib/Zend/Xml/Security.php and app/code/core/Zend/Xml/Security

I also resetted chmod et owner of all website files, the patch was applied via ssh without error

Re: SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

When enabling compiler the error disappear and magento work ! if i disable compiler the error is here again (i refreshed the compilation)

$ php -f compiler.php state
Compiler Status: Disabled
Compilation State: Not Compiled
Collected Files Count: 0
Compiled Scopes Count: 0
$ php -f compiler.php clear
Compilation successfully cleared
$ php -f compiler.php enable
Compilation State: Not Compiled
Please run with option compile
$ php -f compiler.php compile
Compilation successfully finished

 

HERE IT WORK


$ php -f compiler.php disable
Compiler include path disabled
$ php -f compiler.php clear
Compilation successfully cleared

 

HERE ERROR AGAIN

Re: SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

Hi @choussamaster & @simonegiani, can you please confirm that you have installed all previous patches before installing these two? 

 

Also, what version of PHP are you running? 7405 requires PHP 5.4+.

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: SUPEE 7405 and SUPEE 7616 broke Magento 1.9.2

I have the similar Problem. I use Magento 1.9.2.0. It doesn´t work by Installation with Path SUPEE-7405 for CE 1.9.2.0-1.9.2.2 or SUPEE-7405 v1v1 for CE 1.9.2.0 via SSH. Magento breaks with manual trial