cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-7405 on Magento 1.7.0.0

SUPEE-7405 on Magento 1.7.0.0

When installing the SUPEE-7405 on magento 1.7.0.0 the patch is trying to remove the comment on these lines:

 

-/* @var $_helper Mage_Authorizenet_Helper_Data  */
-$_helper = $this->helper('authorizenet');
+/* @var $_helper Mage_Authorizenet_Helper_Admin  */
+$_helper = $this->helper('authorizenet/admin');

However the comment 

@var $_helper Mage_Authorizenet_Helper_Data

was not added until magento 1.7.0.1 and not in 1.7.0.0

 

I have got around the issue by added the comment to the file and then running the patch.

 

 

 

 

2 REPLIES

Re: SUPEE-7405 on Magento 1.7.0.0

Hi @rob3000, were you able to get this working?

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: SUPEE-7405 on Magento 1.7.0.0

I needed to add 

/* @var $_helper Mage_Authorizenet_Helper_Data  */

above the helper declaration comment to the file and then ran the patch again and it worked.