cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-8788 Downloadable Product - Larger File uploads

SUPEE-8788 Downloadable Product - Larger File uploads

Since installing the patch, I cannot upload larger files as downloadable products.
In the region of 130 Mb + then it seems to freeze on "Uploading..."

 

Files below that size work fine. No error messages.
Checked php.ini settings.

Any help appreciated!

20 REPLIES

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Hi @muckmidden this has to do with the new Flow Uploader and the check of ChunkSize, this worked for one of my customers that had the same problem!

 

/js/lib/uploader/flow.min.js

 

Change

chunkSize:1048576

  to

chunkSize:Number.Max_Value

and  change

testChunks:!0

  to

testChunks:false

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Hi @ptomter,

 

Thanks for the response Smiley Happy

When I make those changes, clicking on the file browser "..." no longer brings up the browse for file option.
No errors, it just does nothing Smiley Sad

 

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Should work perfect if you done it correct. You dont have css/java merging turn on ? in that case remember to eather turn it of or clear the java combined to one file catche.

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Checked all of that, however, found an error message:

 

"Uncaught ReferenceError: False is not defined(…)"

 

I'm guessing there is something basic that I am missing!

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Hi @ptomter

 

I solved the problem with the file browser, I changed "False" to "false".

 

The error I get at the moment is:

Failed to load resource: the server responded with a status of 413 (Request Entity Too Large)

 

I have checked my php.ini settings, and they are correct.
The only change has been applying the patch.

 

Re: SUPEE-8788 Downloadable Product - Larger File uploads

413 errors occur when the request body is larger than the server is configured to allow. Here’s how you can fix it, depending on your web server:

  • Apache: Set the LimitRequestBody directive in either your httpd.conf file or a local .htaccess file.

  • Nginx: Set the client_max_body_size directive in nginx.conf

  • IIS: Set the uploadreadaheadsize config setting

As you said you checked you PHP ini file so I gues then that  upload_max_filesize and post_max_size settings in php.ini is high enough. 

Re: SUPEE-8788 Downloadable Product - Larger File uploads

@ptomter

 

Still getting the 413 error Smiley Sad

 

I am not fully confident with .htaccess, so here is what I have changed. Maybe I have it incorrect.

The .htaccess file is located in /media/downloadable

 

The content of the file:

 

Order deny,allow
Deny from all
LimitRequestBody 0

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Hi,

This could be some of the following reasons

 

  • You Hosting provider does not allow for theese types of changes made by users in .htaccess files as it could perform safety issues.
    • Also could be blocked in different location on server. Ex. Mod Sec.
  • They use a Apache version that this caused a problem (Think it was in Apache version 2..0.. something.)
  • The maximum alloved size is 2147483647  (2gb) so try defining this
    http://httpd.apache.org/docs/2.2/mod/core.html#limitrequestbody

I have just now also tested on one of my other servers without any issues there also. Have you checked with your webprovider what their settings are?

Re: SUPEE-8788 Downloadable Product - Larger File uploads

Thank you for your help @ptomter, really appreciated.

 

I'll contact hosting provider to see if anything has changed in their configuration.
If I arrive at a solution, I'll post back on this thread.