cancel
Showing results for 
Search instead for 
Did you mean: 

SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

SOLVED

SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

http://magento.stackexchange.com/questions/141259/security-patch-supee-8788-problem/141273#141273

TLDR: is it safe to apply SUPEE-3941 to 1.7.0.2?

Without applying SUPEE-3941 to 1.7.0.2, SUPEE-8788 does not want to install. After applying SUPPEE-3941 the install goes through. But SUPEE-3941 was not made for 1.7.0.2

Procedure:

1) sh PATCH_SUPEE-1533_EE_1.12.x_v1-2015-02-10-08-19-16.sh -R

2) clear

3) sh PATCH_SUPEE-3941_EE_1.14.0.1_v1-2015-02-10-08-32-02.sh

4) clear

IF HUNK 1 at 40
5) Download vanilla 1.7.0.2 app/design/frontend/base/default/template/catalog/product/view.phtml and copy it to your /app/design/frontend/base/default/template/catalog/product/ folder

5) zip up PATCH_SUPEE-8788_CE_1.7.0.2_v2-2016-10-14-09-32-17.sh

6) upload

7) unzip

8) sh PATCH_SUPEE-8788_CE_1.7.0.2_v2-2016-10-14-09-32-17.sh

17 REPLIES

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Bump.

 

I have the same question. I have not applied 3941 yet because i want to make sure it is safe to do so since I am on 1.7.0.2 

 

On the site is says that SUPEE-3941 is for 1.8.0.0 through 1.9.0.1

 

but here http://devdocs.magento.com/guides/m1x/other/ht_install-patches.html#apply-8788

it says to apply for versions earlier than 1.9.1.0

 

Please advise. Thanks

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

I'll be testing tomorrow the DEV site to see if anything is broken. Obviously I wont be able to determine every issue but so far orders are working and admin pages are not broken.

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

I have the same question.

 

Seems a bit stupid to require a prerequisite patch that isn't available for 1.7!

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Please let us know if you find new issues.

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

I will, but this will really depend on your setup. Everybody has different Themes/Plugins/Payment Gateways.

 

I suggest setting up Development Server that you will be able to test patches/new plugins on. This can be done in 30-3 hours depending on your setup / internet speed / knowledge.

 

Dropping new code on Production site is a bad idea in any case, unless you really dont care about your e-commerce site working.

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Interested to see how this goes for you guys. I've got a handful of sites that predate 1.8 that need patching however I'm stuck for the same reasons you are without a suitable SUPEE-3941....

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Hi all, I talked to our product team and SUPEE-3941 should be fine to apply to lower versions. It exists only to address issues with Connect.

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Thanks Sherrie!

Re: SUPEE-8788 (V2) -- SUPEE-3941 is it safe to apply to 1.7.0.2?

Any hint what to do on versions before 1.7?

SUPEE-3941 will not install on e.g. 1.6.2....